Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#85 2015-03-02 09:44:27

kees-b
Member
From: middelburg, nl
Registered: 2004-03-03
Posts: 235
Website

Re: Edit error: Sorry, the form could not be submitted. Please try again.

I just found that the txp_lib_misc.php fix interferes with the thru_tag plugin. On a site with a large number of tags we use the clickable list from the thru_tags plugin. With the fix applied, when saving an article with tags, all comma’s are removed between the chosen tags, thus creating one new enourmous multi-word tag! They can be re-inserted by hand though and then the comma’s will stick!

Offline

#86 2015-03-02 09:59:41

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 11,084
Website GitHub

Re: Edit error: Sorry, the form could not be submitted. Please try again.

kees-b wrote #288684:

With the fix applied, when saving an article with tags, all comma’s are removed

That’s crazy. Perhaps tru_tags internally uses newlines to delimit its list options, which are being stripped by the patch prior to article save, thus treating the keywords list as a single, humungous string. Someone would have to review the code to find out why.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#87 2016-01-15 18:08:01

gfdesign
Member
From: Argentina
Registered: 2009-04-20
Posts: 401

Re: Edit error: Sorry, the form could not be submitted. Please try again.

Hi community.
I faced with this same problem (the original, not using MPL) in a TXP 4.5.2 site but I was able to fix it as you suggested writing the articles titles of the last five articles again.

However, upgrading to the last version to 4.5.7 didn’t fix the original issue in a cloned installation as I thought. I mean, not correcting the titles just relying the solution would be done by the upgrade.

I hope in a future this issue can be solved
I just wanted to say that. :)

Thanks

Offline

#88 2016-04-12 14:35:38

Leonick
Member
Registered: 2007-07-30
Posts: 16

Re: Edit error: Sorry, the form could not be submitted. Please try again.

I have the same problem on v4.6-dev
I’ve install the v4.6-dev because I think this version solve the recurrent problem on the v4.5.7
but no !

Perhaps this error came from this response “HTTP/1.1 401 Your session has expired” for the “POST /textpattern/index.php HTTP/1.1” ?
Finally, no : I’ve the same problem with HTTP 200 response

Last edited by Leonick (2016-04-12 14:41:03)

Offline

#89 2023-02-17 07:56:32

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,960
Website GitHub Mastodon Twitter

Re: Edit error: Sorry, the form could not be submitted. Please try again.

Revisiting this old thread as I had the same error today, so I’m posting this for future reference. My FF console started returning a 418 error on saving any form or page. The error logs revealed that this was due to an “Execution error – PCRE limits exceeded (-8).” The easy fix was to add

pcre.backtrack_limit = 10000000
pcre.recursion_limit = 10000000

in the Dreamhost’s phprc.


Yiannis
——————————
neme.org | hblack.net | EMAP | A Sea change | NeMe @ github
I do my best editing after I click on the submit button.

Offline

#90 2023-02-17 10:14:54

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,960
Website GitHub Mastodon Twitter

Re: Edit error: Sorry, the form could not be submitted. Please try again.

colak wrote #334651:

Revisiting this old thread as I had the same error today, so I’m posting this for future reference. My FF console started returning a 418 error on saving any form or page. The error logs revealed that this was due to an “Execution error – PCRE limits exceeded (-8).”

Thinking about it, why would the back-end return this error?

Active plugins:

  • act_if_mobile-0.1.2 (modified)
  • adi_matrix-2.1beta5
  • adi_notes-1.4
  • com_connect-4.7.0 (modified)
  • etc_query-1.5.1
  • ext_com_connect_verify-0.1 (modified)
  • ext_file_attach-1.0.5
  • fha_time_diff-0.23
  • ied_plugin_composer-1.2.1
  • mem_postmaster-1.0.20 (modified)
  • oui_cookie-1.0.0-BETA4
  • pap_comconnect-0.1.2 (modified)
  • pat_speeder-1.1
  • rah_external_output-1.0.4
  • rss_admin_db_manager-4.6.0
  • smd_where_used-0.4.0 (modified)
  • wet_opensearch-0.1

Yiannis
——————————
neme.org | hblack.net | EMAP | A Sea change | NeMe @ github
I do my best editing after I click on the submit button.

Offline

#91 2023-02-25 19:29:43

gaekwad
Server grease monkey
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 4,030
GitHub

Re: Edit error: Sorry, the form could not be submitted. Please try again.

colak wrote #334652:

Thinking about it, why would the back-end return this error?

Active plugins:

[…]

That error relates to the ModSecurity web application firewall, not Textpattern.

Offline

#92 2023-02-25 22:20:27

bici
Member
From: vancouver
Registered: 2004-02-24
Posts: 2,016
Website Mastodon

Re: Edit error: Sorry, the form could not be submitted. Please try again.

gaekwad wrote #334761:

That error relates to the ModSecurity web application firewall, not Textpattern.

@colak as i stated earlier, i have seen that with Dreamhost when helping another user. it was never solved. they moved to another host. your mileage may vary////

Last edited by bici (2023-02-25 22:21:18)


…. texted postive

Offline

#93 2023-02-26 13:47:46

gaekwad
Server grease monkey
From: People's Republic of Cornwall
Registered: 2005-11-19
Posts: 4,030
GitHub

Re: Edit error: Sorry, the form could not be submitted. Please try again.

bici wrote #334765:

i have seen that with Dreamhost when helping another user.

This. Dreamhost certainly deploys it (with some quite sensitive settings for relatively unknown web apps like Textpattern), I think GoDaddy deploy it too.

Offline

#94 2023-02-26 18:13:16

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,960
Website GitHub Mastodon Twitter

Re: Edit error: Sorry, the form could not be submitted. Please try again.

Thanks fr all your advice! I have no idea why the error appeared. I’m hosting a number of domains, only one of which, returned the error. I’m glad the solution was easy.


Yiannis
——————————
neme.org | hblack.net | EMAP | A Sea change | NeMe @ github
I do my best editing after I click on the submit button.

Offline

Board footer

Powered by FluxBB