Textpattern CMS support forum

You are not logged in. Register | Login | Help

#31 2012-08-28 07:13:54

nephou
New Member
Registered: 2012-08-28
Posts: 1

Re: Feedback to: Textpattern 4.5.0 released

Hello, while my 4.4.1 installation of works nicely, I get the following php error message when trying to update to 4.5 :
Parse error: syntax error, unexpected '=', expecting ')' in /homez.13/nulleparu/www/textpattern/lib/txplib_misc.php on line 869

I don’t use any extension and the site works again when rolling back to version 4.4.1

Thanks for reading

Oops! replying to myself:

OVH shared servers are set to interprete PHP 4 by default unless something else is specified. I just added a line in the .htaccess file (SetEnv PHP_VER 5) and now it works.

Sorry

Last edited by nephou (2012-08-28 07:28:57)

Offline

#32 2012-08-28 08:46:52

Gocom
Plugin Author
From: Helsinki, Finland
Registered: 2006-07-14
Posts: 4,533
Website

Re: Feedback to: Textpattern 4.5.0 released

philwareham wrote:

Can you confirm, is that Chrome on Windows, and which version of browser? Looks fine on Chrome v22 on my Mac here.

Try to zoom in or increase text-size as in mlsmith’s screenshot. That breadcrumb bar, and for instance, the drop down menus get bit misaligned like that when changing base text-size from the 16 px, scaling or zooming in.

Offline

#33 2012-08-28 09:37:47

kees-b
Member
From: middelburg, nl
Registered: 2004-03-03
Posts: 234
Website

Re: Feedback to: Textpattern 4.5.0 released

Hi,

I noticed that <txp:article pgonly=“1” /> behaviour has changed. For some reason I used this attribute sometimes with an article tag together with another status=“sticky” article tag with pgonly=“0”. The sticky articles were used to show lists of ‘normal’ articles in the same section. Before 4.5 clicking on such a link did display the status=“4” article even whith the pgonly=“1” attribute. From now on nothing is displayed anymore (as it should I think). Workarounds are not that difficult, but remembering where I used this odd functionality somewhat more.

Apart from that I’m very happy with 4.5!

Looking forward to a MLP upgrade too.

-k

Last edited by kees-b (2012-08-28 14:28:28)

Offline

#34 2012-08-28 10:07:12

philwareham
Core designer
From: Farnham, Surrey, UK
Registered: 2009-06-11
Posts: 3,209
Website

Re: Feedback to: Textpattern 4.5.0 released

@gocom

Looks like Chrome rendering slightly wrong when at enlarged/reduced sizes – scaling is totally fine in latest webkit builds though, which is supposed to be identical rendering engine. Not much of an issue, but I’ll keep an eye on this when we do 4.6. It’s still an improvement over the old admin themes which didn’t scale well at all.

Offline

#35 2012-08-28 10:23:48

philwareham
Core designer
From: Farnham, Surrey, UK
Registered: 2009-06-11
Posts: 3,209
Website

Re: Feedback to: Textpattern 4.5.0 released

@mlsmith

The duplicated comments issue – do you have ‘Automatically append comments to articles’ turned on in the prefs? If so, turn that off.

I’m going to discuss with the other devs whether we should even keep that pref in future – I guess it’s some legacy option from way back in Textpattern history (which I never turn on myself).

Offline

#36 2012-08-28 10:49:42

Gocom
Plugin Author
From: Helsinki, Finland
Registered: 2006-07-14
Posts: 4,533
Website

Re: Feedback to: Textpattern 4.5.0 released

Phil, the option is on by default. Removing it will break existing sites, unless you can somehow magically inject new tags to correct locations on the users’ templates, or how the magical comments are no longer appearing magically.

That said, did anyone actually do clean test installs, running through the setup progress couple times before packaging 4.5, lol. Based on the errors it seems that the answer is no. Otherwise you would have noticed the error right away on the landing page.

I suppose no one in the community did either, including me. Haven’t installed Textpattern in 5 years or so using the setup progress.

I’m not actually that surprised about the human errors. Since the templates are managed separately and copied in manually after. Couldn’t be bad in my opinion to make the template management bit easier for Phil. Since keeping up version numbers in some source file is hard, that must be total hell. Some awkward SQL export mangled in PHP, ugh.

Offline

#37 2012-08-28 10:56:14

philwareham
Core designer
From: Farnham, Surrey, UK
Registered: 2009-06-11
Posts: 3,209
Website

Re: Feedback to: Textpattern 4.5.0 released

Is that pref on by default nowadays? I just did a clean install from Txp4.5 and I think that pref was already set to ‘off’?

EDIT: yes, I can confirm that option is always set to ‘off’ in new installs of Textpattern (I do remember a long time ago it used to be default ‘on’ which confused the hell out of me at the time, but now it’s not).

Last edited by philwareham (2012-08-28 11:18:39)

Offline

#38 2012-08-28 11:02:43

wet
Developer
From: Lenzing, Austria
Registered: 2005-06-06
Posts: 3,267
Website

Re: Feedback to: Textpattern 4.5.0 released

Gocom wrote:

That said, did anyone actually do clean test installs, running through the setup progress couple times before packaging 4.5, lol.

This was me, four times to be exact. Once for each archive format, each for a fresh install and for the update. I’m glad you find this funny.

I’m not actually that surprised about the human errors. Since the templates are managed separately and copied in manually after.

In real life this is done by a git pull and a plugin. We think that we failed at the merge for yet unknown reasons.

Last edited by wet (2012-08-28 11:06:50)

Offline

#39 2012-08-28 11:12:14

mlsmith
New Member
Registered: 2012-08-27
Posts: 5

Re: Feedback to: Textpattern 4.5.0 released

philwareham wrote:

@mlsmith
Can you confirm, is that Chrome on Windows, and which version of browser? Looks fine on Chrome v22 on my Mac here.

It was Chrome in Ubuntu 12.04. I don’t believe that I was zooming in at all.

Last edited by mlsmith (2012-08-28 11:12:52)

Offline

#40 2012-08-28 11:13:57

mlsmith
New Member
Registered: 2012-08-27
Posts: 5

Re: Feedback to: Textpattern 4.5.0 released

philwareham wrote:

Is that pref on by default nowadays? I just did a clean install from Txp4.5 and I think that pref was already set to ‘off’?

It was my bad…I turned it on but it was off by default.

Offline

Board footer

Powered by FluxBB