Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#37 2012-02-14 17:08:33

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,538
Website GitHub

Re: smd_browse_by: browse articles, images, files and links by category

philwareham wrote:

the code of the plugin should really have <p> tags included and &nbsp; removed like so…

Thanks. Try the new beta : it’s the closest I can get. It wraps the entire input section (hidden and select input) with a para tag. The downside is that it takes up more vertical real estate out of the box, which is more scrolling. Hmmmmmm.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#38 2012-02-14 17:32:47

philwareham
Core designer
From: Haslemere, Surrey, UK
Registered: 2009-06-11
Posts: 3,541
Website GitHub Twitter

Re: smd_browse_by: browse articles, images, files and links by category

Cheers, that’s better!

Offline

#39 2012-02-22 16:42:18

totoff
Member
From: Cologne, Germany
Registered: 2011-04-04
Posts: 145
Website

Re: smd_browse_by: browse articles, images, files and links by category

hello forum

weired, i have two installations of txp 4.4.1 both with hive backend theme and smd_browse_by installed. in one installation the plugin works perfectly fine, in the other it doesn’t. the non-working installation was an update from 4.4.0 while the other was a fresh install. before the update i had lam_browse_by installed but i did uninstall it before i installed smd_browse_by.

any hint how to solve this is much appreciated.

christoph

Offline

#40 2012-02-24 20:52:53

totoff
Member
From: Cologne, Germany
Registered: 2011-04-04
Posts: 145
Website

Re: smd_browse_by: browse articles, images, files and links by category

hello forum,

i’m a bit desperate now as i can’t get smd_browse_by to work on my updated install while my client wants it …

i did uninstall and re-install the plugin twice, disabled all other plugins and changed the admin theme back to default but to no avail. does somebody know any other check i can perform or how to solve this?

thanks, christoph

Offline

#41 2012-02-24 21:05:09

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,259

Re: smd_browse_by: browse articles, images, files and links by category

Have you tried changing the load order of smd_browse_by? If this doesn’t help try isolating conflicting plugins (wet_plugout makes it an easier process, link is in my signature).

(Viel Glück!)

Last edited by uli (2012-02-24 21:06:44)


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#42 2012-02-24 21:12:04

totoff
Member
From: Cologne, Germany
Registered: 2011-04-04
Posts: 145
Website

Re: smd_browse_by: browse articles, images, files and links by category

thanks for your reply uli,

unfortunately no glück at all, it doesn’t help :-( i already deactivated all other plugins, again no glück. guess it must have to do with lam_browse_by that was installed before the update …

Offline

#43 2012-03-19 12:06:57

totoff
Member
From: Cologne, Germany
Registered: 2011-04-04
Posts: 145
Website

Re: smd_browse_by: browse articles, images, files and links by category

hello stef,

i’m pushing this as i still haven’t found a solution (smd_browse_by broken after update from 4.4.0 > 4.4.1). i checked diagnostics and everything is ok with the update, only smd_browse_by has stopped working.

is there a way to file a bug report? i this a bug?

thanks, christoph

Offline

#44 2012-03-19 12:19:24

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,538
Website GitHub

Re: smd_browse_by: browse articles, images, files and links by category

totoff wrote:

is there a way to file a bug report? i this a bug?

It’s very odd. I can’t honestly see this as being a bug with the plugin (but never say never!) because it’s so simple it just hooks into the events on the various tabs. A few things to check:

  1. Are you using the beta?
  2. Does the browse dropdown appear on any of the tabs? Images, Files, Links…? Or is only one missing?
  3. Have you set up a hidden pref called smd_browse_by. If so, remove it.
  4. Edit the plugin code and add echo 'Hello!'; on line 2 (immediately after if (txpinterface == 'admin') {). When you visit a tab afterwards, do you see Hello! written to every tab? If so, the plugin is being called and you can delete the extra line. If not, check it’s activated and that lam_browse_by is removed (though they shouldn’t conflict, it’s worth removing the lam plugin if mine is also installed).

Try those first and let me know how you get on.

Last edited by Bloke (2012-03-19 12:20:48)


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#45 2012-03-19 12:35:26

totoff
Member
From: Cologne, Germany
Registered: 2011-04-04
Posts: 145
Website

Re: smd_browse_by: browse articles, images, files and links by category

thank you stef,

“1. Are you using the beta?”

not as far as i can tell. at the time of update definitely not. as i did uninstall and reinstall several times afterwards i can’t guarantee i haven’t catched the beta by accident. diagnostics say it’s version 0.10.

“2. Does the browse dropdown appear on any of the tabs? Images, Files, Links…? Or is only one missing?”

missing on any tab

“3. Have you set up a hidden pref called smd_browse_by. If so, remove it.”

i’m sorry to say, but don’t know what a hidden pref is …

4. “do you see Hello! written to every tab?”

positive. it echoes “Hello” on any tab.

EDIT: at the time of update no plugin was installed. did uninstall lam_browse_by, updated, installed smd_browse_by.

Last edited by totoff (2012-03-19 12:37:44)

Offline

#46 2012-03-19 12:51:45

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,538
Website GitHub

Re: smd_browse_by: browse articles, images, files and links by category

totoff wrote:

[beta] not as far as i can tell.

OK, just wondered. Might be worth a shot (although 0.10 should work fine anyway).

i’m sorry to say, but don’t know what a hidden pref is …

I’ll rule that out then!

it echoes “Hello” on any tab.

Hmmm, so it’s definitely running the plugin but it’s not attaching itself to the interface on any of the tabs. OK, a few more things:

  1. What version of jQuery do you have installed?
  2. Check it’s being loaded ok (refresh the page with the ‘Net’ pane visible in Firebug, for example — look for red as a warning! Or View Source and check the links to jQuery are resolving correctly)

As long as javascript is enabled on the browser for the site and jQuery is loading fine, I can’t think of any other reason the plugin would be running but not visible.

Last edited by Bloke (2012-03-19 12:52:32)


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#47 2012-03-19 13:11:02

totoff
Member
From: Cologne, Germany
Registered: 2011-04-04
Posts: 145
Website

Re: smd_browse_by: browse articles, images, files and links by category

jquery is 1.6.1 and loaded as it should.

does the markup of the backend help? as far as i can see there is no space reserverd for the plugin:

    <body id="page-list" class="content">
      <div id="txp-head" class="clearfix"></div>
      <div id="txp-body">
        <p id="messagepane"></p>
        <div id="txp-content">
          <div id="list_control" class="txp-control-panel">
            <form method="get" action="index.php" class="search-form"></form>
          </div>
          <div id="list_container" class="txp-container txp-list"></div>
          <script type="text/javascript"></script>
          <style type="text/css"></style>
        </div>
      </div>
      <div style="display: none" id="hiddenlpsubmitdiv"></div>
      <script></script>
    </body>

the site has some jquery scripts running on the frontend (e.g. jquery cycle). may they interfere with the plugin?

Offline

#48 2012-03-19 13:24:36

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,538
Website GitHub

Re: smd_browse_by: browse articles, images, files and links by category

totoff wrote:

as far as i can see there is no space reserverd for the plugin:

It won’t show up in the View Source because it’s loaded afterwards, but if you view the source in Firebug you should see it (I’m assuming you don’t see any other javascript errors in the Console that might be preventing the plugin from running?)

For reference, the plugin injects itself above the class="search-form" form. Your markup looks like a standard Hive setup. And no front-side plugin should interfere.

A puzzler for sure. If you can’t see any console errors, which is my last ditch attempt at figuring this out, the only other thing I can suggest is if you permit me a login so I can have a look around and see if I can figure something out. After that I’m out of ideas, sorry.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

Board footer

Powered by FluxBB