Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#253 2014-04-01 09:54:59

tye
Member
From: Pottsville, NSW
Registered: 2005-07-06
Posts: 858
Website

Re: smd_thumbnail: manage multiple thumbnails of your images

Thanks Stef :) I’m running:

txp 4.5.5
bot_image_upload 0.6.3
smd_thumbnail 0.30

btw – not sure if you advertise the capabilities of smd_thumbnail as much as you should, I checked it a while back, and it was ok – now it has entered the realm of awesomeness :) I’ll try help in some way

Offline

#254 2014-04-25 12:07:47

jstubbs
Moderator
From: Hong Kong
Registered: 2004-12-13
Posts: 2,395
Website

Re: smd_thumbnail: manage multiple thumbnails of your images

Hi Stef, not sure if I’m getting an smd_thumbnail specific error or if it is an issue with core:

Fatal error: Call to undefined method smd_thumb::wet_thumb() in /srv/my_server/www/my_domain.com/htdocs/textpattern/lib/txplib_misc.php(1753) : eval()'d code on line 260

This is after updating (by mistake!) to a nightly build of TXP on this site. So I think its a core issue, but I thought this particular issue had been resolved?

Offline

#255 2014-04-25 13:50:32

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,268

Re: smd_thumbnail: manage multiple thumbnails of your images

jstubbs wrote #280402:

This is after updating (by mistake!) to a nightly build of TXP on this site.

Then it’s probably related with this here. (See also posts above about the wet_thumb error.)


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#256 2014-04-25 19:58:45

Gocom
Developer Emeritus
From: Helsinki, Finland
Registered: 2006-07-14
Posts: 4,533
Website

Re: smd_thumbnail: manage multiple thumbnails of your images

jstubbs wrote #280402:

Hi Stef, not sure if I’m getting an smd_thumbnail specific error or if it is an issue with core

It’s the plugin version you have. Seems that you are using old version of smd_thumbnail that is trying to extend the now gone PHP4 style constructor. Those mentioned issues and changes are unrelated.

Last edited by Gocom (2014-04-25 19:59:29)

Offline

#257 2014-04-26 01:13:18

jstubbs
Moderator
From: Hong Kong
Registered: 2004-12-13
Posts: 2,395
Website

Re: smd_thumbnail: manage multiple thumbnails of your images

That’s weird because the plugin version was 0.30 which is the latest version. I downloaded it again and installed and the thumbnail production now works again. !!

Offline

#258 2014-04-30 23:30:24

maniqui
Member
From: Buenos Aires, Argentina
Registered: 2004-10-10
Posts: 3,070
Website

Re: smd_thumbnail: manage multiple thumbnails of your images

On smd_thumbnail v0.30 and TXP 4.6dev: I can’t see the “Keep Txp thumbnails in sync with default profile” option nor I can find a way to create the (built-in) Txp thumbnail for an image.
BTW, if I disable the plugin, I can see the “Create thumbnail” option on an “Edit image” page.

My bad: there wasn’t any profile set as “Default”, so the sync option was being kept hidden. The plugin help is pretty clear about that. Sorry. :)

Last edited by maniqui (2014-05-01 00:40:23)


La música ideas portará y siempre continuará

TXP Builders – finely-crafted code, design and txp

Offline

#259 2014-09-12 19:08:15

RedFox
Member
From: Netherlands
Registered: 2005-03-25
Posts: 783
Website

Re: smd_thumbnail: manage multiple thumbnails of your images

Very strange. The plug-in suddenly stopped creating thumbnails … !? Tried everything, even installed smd_thumbnails again. Help please!

Textpattern 4.5.5 and smd_thumbnails 0.30

Diagnose:

Textpattern versie: 4.5.5 (r5575)
Laatste update: 2014-03-08 07:55:22/2014-03-08 07:54:49
Document root: /var/www/vhosts/claraelders.nl/httpdocs
$path_to_site: /var/www/vhosts/claraelders.nl/httpdocs
Pad naar textpattern: /var/www/vhosts/claraelders.nl/httpdocs/textpattern
Permanente link modus: section_title
open_basedir: /var/www/vhosts/claraelders.nl/httpdocs:/tmp
tijdelijke bestanden map: /var/www/vhosts/claraelders.nl/httpdocs/textpattern/tmp
Site URL: www.claraelders.nl
PHP versie: 5.2.3
GD Graphics Library: bundled (2.0.34 compatible); ondersteunde bestandssoorten: GIF, JPG, PNG.
Server TZ: Europe/Berlin
Lokale servertijd: 2014-09-12 21:05:53
Zomertijd: 1
Zomer- en wintertijd automatisch bijstellen?: 1
Tijdzone: Europe/Amsterdam (3600)
MySQL: 5.0.27
Localisatie: nl_NL.UTF-8
Server: Apache/2.0.54 (Fedora)
Apache versie: Apache/2.0.54 (Fedora)
PHP server API: apache2handler
RFC 2616 headers:
Besturingssysteem van de server: Linux 2.6.9-023stab053.2-smp
Actieve plugins: jra_ext_link-0.2, rah_time-0.1, yab_email-0.6, adi_notes-1.1.1, smd_macro-0.20, stm_article_order-0.2.4m, wet_peex-0.4, smd_thumbnail-0.30
Vormgeving sitebeheer: classic 4.5.5

inhoud .htaccess bestand:
————————————
#DirectoryIndex index.php index.html

#Options +FollowSymLinks
#Options -Indexes
#ErrorDocument 403 default

<IfModule mod_rewrite.c> RewriteEngine On #RewriteBase /relative/web/path/

RewriteCond %{REQUEST_FILENAME} -f [OR] RewriteCond %{REQUEST_FILENAME} -d RewriteRule ^(.+) – [PT,L]

RewriteCond %{REQUEST_URI} !=/favicon.ico RewriteRule ^(.*) index.php

RewriteCond %{HTTP:Authorization} !^$ RewriteRule .* – [E=REMOTE_USER:%{HTTP:Authorization}]
</IfModule>

#php_value register_globals 0

#SVG
AddType image/svg+xml svg svgz
AddEncoding gzip svgz

————————————

Click for screendump

[edit]
Repeared the database (tables) … still no thumbnails … :(

[edit]
There’s a .htacces file in the images folder (root) …

AddHandler cgi-script .php .pl .jsp .asp .sh .cgi
Options -ExecCGI

… what’s it doing there?

Last edited by RedFox (2014-09-13 09:25:39)

Offline

#260 2014-09-12 21:05:02

GugUser
Member
From: Quito (Ecuador)
Registered: 2007-12-16
Posts: 1,469

Re: smd_thumbnail: manage multiple thumbnails of your images

Maybe out of context: Why this “1. SVG” isn’t commented?

Offline

#261 2014-09-13 03:10:05

RedFox
Member
From: Netherlands
Registered: 2005-03-25
Posts: 783
Website

Re: smd_thumbnail: manage multiple thumbnails of your images

Oops … typo gives Textile (list): # SVG versus #SVG

Offline

#262 2014-09-14 08:32:15

RedFox
Member
From: Netherlands
Registered: 2005-03-25
Posts: 783
Website

Re: smd_thumbnail: manage multiple thumbnails of your images

If I make a new profile (with a new name) a thumbnail is rendered … :)
So I deleted all existing profiles and made new ones (with the same names and dimensions). But … no thumbnails … :(
Where can I have a look (file) to see if there’s some hacking going on?

Last edited by RedFox (2014-09-14 08:34:38)

Offline

#263 2014-09-14 09:50:10

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,714
Website GitHub

Re: smd_thumbnail: manage multiple thumbnails of your images

RedFox wrote #283734:

If I make a new profile (with a new name) a thumbnail is rendered … :) So I deleted all existing profiles and made new ones (with the same names and dimensions). But … no thumbnails

Very odd. The only thing I can think of is the permissions in the images/<name-of-your-profile> folder. Perhaps the new profile is being created with different permissions, so compare them and perhaps alter the permissions of the existing folder? That’s a long shot: when you deleted the old profile it should have removed the folder and recreated it when you made the new one. It’s possible it couldn’t delete the old folder though. Anything in your server logs that might give us a clue? Any error_log files inside your document root or textpattern folders that might shed some light?

What is the name of the profile that is giving you trouble? It’s odd that it was working and then just stopped.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#264 2014-09-14 10:22:58

RedFox
Member
From: Netherlands
Registered: 2005-03-25
Posts: 783
Website

Re: smd_thumbnail: manage multiple thumbnails of your images

Bloke wrote #283735:

Very odd. The only thing I can think of is the permissions in the images/<name-of-your-profile> folder. Perhaps the new profile is being created with different permissions, so compare them and perhaps alter the permissions of the existing folder?

Very odd indeed. The new profile (folder) has the same permissions as the existing ones (755) and gives a thumbnail. Nevertheless I changed the permissions of an existing profile into 777 and guess what? It gives a thumbnail.

!?

Last edited by RedFox (2014-09-14 10:38:52)

Offline

Board footer

Powered by FluxBB