Textpattern CMS support forum

You are not logged in. Register | Login | Help

#101 2009-11-22 03:13:00

iblastoff
Plugin Author
From: Toronto
Registered: 2006-06-11
Posts: 1,197
Website

Re: [plugin] [ORPHAN] kml_twitter: Kimili Twitter Timeline

hmm i also get the immediate “Rate limit exceeded. Clients may not make more than 150 requests per hour.” error when i use this plugin (v1.2 with txp 4.2.0). just using the simple tag <txp:kml_twitter user="username" count="1" /> and thats it.

the /textpattern/cache directory is created and is writeable (777).

i see the .cache file in there and changed its permission to 666 as well just in case.

Last edited by iblastoff (2009-11-22 03:13:48)

Offline

#102 2009-12-11 16:30:35

kimili
Plugin Author
From: Massachusetts, USA
Registered: 2004-06-17
Posts: 108
Website

Re: [plugin] [ORPHAN] kml_twitter: Kimili Twitter Timeline

Today, I’ve released a long-overdue update to Kimili Twitter Timeline. Version 1.3 of Kimili Twitter Timeline fixes a number of bugs, implements a number of requested features and gives you even more flexibility to customize the display of your tweets. Changes include:

  • Added the ability to hide replies.
  • More flexible HTML customization.
  • Fixed an issue that occurred when using Textile.
  • More flexible boolean handling on attribute values (can now be true/false, 1/0 and yes/no).
  • Fixed a problem with how tweet IDs were being handled on some servers. _(thanks to Christopher Horrell
  • Replaced deprecated PHP functions.
  • Improved parsing of URLs in tweet text.

You can download it now at the Kimili Twitter Timeline Homepage

Offline

#103 2009-12-11 17:38:40

mrtunes
Member
From: Toronto, On
Registered: 2007-03-12
Posts: 575
Website

Re: [plugin] [ORPHAN] kml_twitter: Kimili Twitter Timeline

great thanks. i’ve been getting into your plugin more lately and i think it was good even before the update. this is good to see more improvements.

Offline

#104 2009-12-11 17:49:34

TNT
Member
From: Rotterdam, Netherlands
Registered: 2006-01-06
Posts: 248
Website

Re: [plugin] [ORPHAN] kml_twitter: Kimili Twitter Timeline

Working perfectly! Thanks!


Prrrrrrrr

Offline

#105 2010-01-04 03:35:04

mrtunes
Member
From: Toronto, On
Registered: 2007-03-12
Posts: 575
Website

Re: [plugin] [ORPHAN] kml_twitter: Kimili Twitter Timeline

i see there is the conversation order feature, i’m wondering if there is a way to not display tweets that you’ve written which start with @username ?

Offline

#106 2010-01-04 15:11:35

kimili
Plugin Author
From: Massachusetts, USA
Registered: 2004-06-17
Posts: 108
Website

Re: [plugin] [ORPHAN] kml_twitter: Kimili Twitter Timeline

@mrtunes – In the new version (1.3), I’ve added a show_replies attribute which, when set to false (or 0 or no) will hide replies you’ve made to other people.

Offline

#107 2010-02-14 19:01:43

vlb1176
New Member
Registered: 2010-02-14
Posts: 1

Re: [plugin] [ORPHAN] kml_twitter: Kimili Twitter Timeline

kimili wrote:

@corkingdesign – It sounds like you’ve not got the plugin’s caching set up properly. There’s a few things to check:

  1. The cache_life attribute is set to something higher than 0. (default is 600)
  2. You’ve created a /textpattern/cache/ directory
  3. The /textpattern/cache/ directory permissions should be set to 777 (World writable)

If any of those items are not as I describe, the plugin won’t create a cache file, but will hit Twitter for content on every page view. That’s probably why you’re going over the limit.

Hi kimili,

I to am having the same error display… I have all the settings you suggested / cache_life=“600”, cache directory in textpattern directory, and the cache folder chmod setting is 777. but i still keep getting this errow… Rate limit exceeded. Clients may not make more than 150 requests per hour.

I’ve also tried setting the cache_life between 1 and 800 and still get the error.

Any idea what it might be?

Offline

#108 2010-04-30 12:38:48

kevinpotts
Member
From: Kansas City
Registered: 2004-12-07
Posts: 364
Website

Re: [plugin] [ORPHAN] kml_twitter: Kimili Twitter Timeline

I am running into the Dec 31, 1969 issue. All of my tweets disappear, the timestamp becomes Dec 31, 1969 and just links to twitter.com/status. I am running version 1.3 of the plugin (since day one). I deleted the cache file, set CACHE_LIFE to “1” temporarily, made sure all DB tables were repaired, dumped everything browser-side (just in case), but nothing. I have not actually done anything to the site in the past few days, so I don’t think I broke anything.

Here is the source for the cache file:

O:8:"stdClass":1:{s:6:"errors";a:1:{i:0;O:8:"stdClass":2:{s:4:"code";i:32;s:7:"message";s:27:"Could not authenticate you.";}}}

So I am not sure what’s going on, but no other Twitter clients have any problem with my username.

Any help would be greatly appreciated.

Last edited by kevinpotts (2010-04-30 12:44:43)

Offline

#109 2010-04-30 21:09:16

johnstephens
Plugin Author
From: Woodbridge, VA
Registered: 2008-06-01
Posts: 989
Website

Re: [plugin] [ORPHAN] kml_twitter: Kimili Twitter Timeline

Same problem here. Could it be a change in the way Twitter is handling authentication? I’ve used this plugin for at least a year and I’ve never seen this until today. I’m sure it was working yesterday.

Offline

#110 2010-05-01 02:03:05

kevinpotts
Member
From: Kansas City
Registered: 2004-12-07
Posts: 364
Website

Re: [plugin] [ORPHAN] kml_twitter: Kimili Twitter Timeline

OK, so that error went away, and now I am getting this:

There was a problem retrieving data from Twitter.

Offline

Board footer

Powered by FluxBB