Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#871 2017-07-29 08:26:23

Kjeld
Member
From: Tokyo, Japan
Registered: 2005-02-05
Posts: 263
Website

Re: yab_shop (simple textpattern shop with paypal support)

ruud wrote #306480:

If you send me a username/password, I’ll have a look.

Oh, that is extremely generous of you, Ruud. Thank you. Will send it right away.


JapaneseStreets.com – Japanese street fashion (mostly txp)
Old Photos of Japan – Japan between 1860 and 1940 (100% txp)
MeijiShowa – Stock photos of Japan between 1860 and 1940 (100% txp)

Offline

#872 2017-07-29 09:59:41

ruud
Developer emeritus
From: a galaxy far far away
Registered: 2006-06-04
Posts: 5,068
Website

Re: yab_shop (simple textpattern shop with paypal support)

Code in my earlier post is corrected now. Let us know if it works.

Offline

#873 2017-07-29 10:53:56

Kjeld
Member
From: Tokyo, Japan
Registered: 2005-02-05
Posts: 263
Website

Re: yab_shop (simple textpattern shop with paypal support)

ruud wrote #306482:

Code in my earlier post is corrected now. Let us know if it works.

I just finished testing the new code in Safari and Chrome, and it works perfectly. I encounter no problems. Hopefully, this additional code can soon be added to the actual plugin by Trenc so other yab_shop users can benefit from it even when not aware of this exchange here.

Thank you very much, Ruud. I appreciate it immensely!


JapaneseStreets.com – Japanese street fashion (mostly txp)
Old Photos of Japan – Japan between 1860 and 1940 (100% txp)
MeijiShowa – Stock photos of Japan between 1860 and 1940 (100% txp)

Offline

#874 2017-10-27 10:16:50

trenc
Plugin Author
From: Cologne
Registered: 2008-02-27
Posts: 565
Website

Re: yab_shop (simple textpattern shop with paypal support)

Thanks for your input.

But unfortunately this would disable the last modified headers only on the checkout section. If someone runs a shop across different sections and is using the small cart widget, he/she has to disable the last modified header prefs either way.

I’m afraid this would be more confusing. Or I am wrong here?

But since this seems to be a topic maybe we should disable this pref for all yab_shop related sites in core by default?

Last edited by trenc (2017-10-27 10:19:41)

Offline

#875 2017-10-27 12:12:02

Kjeld
Member
From: Tokyo, Japan
Registered: 2005-02-05
Posts: 263
Website

Re: yab_shop (simple textpattern shop with paypal support)

trenc wrote #307548:

But since this seems to be a topic maybe we should disable this pref for all yab_shop related sites in core by default?

I’ll happily follow whatever you believe is best.


JapaneseStreets.com – Japanese street fashion (mostly txp)
Old Photos of Japan – Japan between 1860 and 1940 (100% txp)
MeijiShowa – Stock photos of Japan between 1860 and 1940 (100% txp)

Offline

#876 2017-11-10 07:10:07

sgreener
Member
Registered: 2008-11-05
Posts: 16

Re: yab_shop (simple textpattern shop with paypal support)

My website is Textpattern powered, though I am not a Textpattern guru: barely proficient I would say.

I am in the market for a shopping trolley application that can work from a database of products (no more than 10-20).

I note that out in the non-Textpattern world there are a lot of these sorts of applications.
I don’t know how easy it would be to integrate one of these with my website.
I have been considering porting my whole website to another CMS to get access to those shopping trolley applications.

Then I found this project, the only Textpattern one that seems to be working and operating.

Question is, is this project stable enough to warrant the effort to implement?
Are there any people who can help me with the implementation?

regards
Simon

Offline

#877 2018-03-14 17:26:37

THE BLUE DRAGON
Member
From: Israel
Registered: 2007-11-16
Posts: 595
Website

Re: yab_shop (simple textpattern shop with paypal support)

Hi, I’m also getting these errors on a fresh install on TXP 4.6.2, how can I solve this please?
Using plugin version 0.8.2 (yab_shop_v0.8.2.tar.gz)

rewQ wrote #305807:

Hello! TXP 4.6.2, php 5.4. I’ve installed yab_shop, but i see error “user_error specified key was too long max key length is 1000 bytes “ Please, advise where is error?

User_Error “Specified key was too long; max key length is 1000 bytes”
in /home/users/9/—————-/domains/———/textpattern/lib/txplib_db.php at line 409.

adminErrorHandler()
textpattern/lib/txplib_db.php:409 trigger_error()
textpattern/lib/txplib_misc.php(1782) : eval()’d code:968 safe_query()
textpattern/lib/txplib_misc.php(1782) : eval()’d code:192 yab_shop_install()
textpattern/lib/txplib_misc.php(1782) : eval()’d code:89 yab_shop_first_install()
yab_shop_prefs()
textpattern/lib/txplib_misc.php:1895 call_user_func_array()
textpattern/index.php:214 callback_event(

Offline

#878 2018-05-14 00:26:12

sgreener
Member
Registered: 2008-11-05
Posts: 16

Re: yab_shop (simple textpattern shop with paypal support)

I have downloaded, installed and activated version 0.8.2 of yab_shop into Textpattern CMS · 4.5.5.

When I go to Extensions>Shop_Prefs/Shop_Lang I get:

Yab Shop 0.8.2 – Install
If you have a version before 0.8.x installed, please remove them.
Hit the button to install Yab Shop.

It doesn’t matter how many times I press Install I keep getting exactly the same message.

When I use PhpMyAdmin I can see the following tables:

txp_yab_shop_lang
txp_yab_shop_prefs

with data in both.

Any idea what is going on with Preferences?

SImon

Offline

#879 2018-05-14 17:10:52

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,225

Re: yab_shop (simple textpattern shop with paypal support)

Simon, TXP v4.5.5 is from 2013, if the date I’ve downloaded that TXP zip is correct. So maybe the yab_shop plugin from 2017, which I’ve filed for 4.6, doesn’t work with 4.5.5.

As no earlier version of the shop plugin seems to be available online any more I can offer you to mail you a copy of my 0.8.1 from 2012 (currently I can’t upload to TXP Resources because of server errors). You’d then better delete the 0.8.2 yab tables, and install 0.8.1. If that goes well and is operable, make a db backup and install 0.8.2. Maybe you’ll have more luck then. If not you can still use your backup.


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#880 2018-05-15 06:44:20

sgreener
Member
Registered: 2008-11-05
Posts: 16

Re: yab_shop (simple textpattern shop with paypal support)

Thanks Uli.

I will email you to get 0.8.1.

I am also investigating what is needed to update my current version as I didn’t do the last install.

Offline

Board footer

Powered by FluxBB