Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#49 2008-12-01 11:30:50

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,286

Re: rvm_privileged v0.4

Hi Ruud,

on a 4.0.4 I currently have to use I get an error call to undefined function is_logged_in() with v0.3 of rvm_priviliged. I think this is due to the versions I combine. Do you have an apt version around you can put up a link to?
Thanks!


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#50 2008-12-01 11:38:04

ruud
Developer Emeritus
From: a galaxy far far away
Registered: 2006-06-04
Posts: 5,068
Website

Re: rvm_privileged v0.4

Uli, please upgrade to TXP 4.0.7. The is_logged_in function was added in TXP 4.0.6 and this plugin never had a version that worked with pre-4.0.6 TXP versions.

Last edited by ruud (2008-12-01 11:39:13)

Offline

#51 2009-02-22 11:29:00

the_ghost
Plugin Author
From: Minsk, The Republic of Belarus
Registered: 2007-07-26
Posts: 907
Website

Re: rvm_privileged v0.4

I try to use example in first post, but it seems that set_error_status doesn’t affect production status in my install (4.0.8).

Here is my call (placed in the top of Page)
<txp:rvm_if_privileged level="1,2"><txp:php>set_error_level('live');</txp:php></txp:rvm_if_privileged>

But in the bottom of template i place
<!-- logged - <txp:rvm_privileged_user />; <txp:rvm_privileged_user type="privilege" /> -->
and recieve
<!-- logged - Виктор; publisher -->

  1. Here is page output in debug mode (debug mode set via admin side)
  2. Full diag is avaible here
  3. Live site is here

Providing help in hacking ATM! Come to courses and don’t forget to bring us notebook and hammer! What for notebook? What a kind of hacker you are without notebok?

Offline

#52 2009-06-22 13:46:52

lothar99
Member
Registered: 2009-03-20
Posts: 35

Re: rvm_privileged v0.4

This plugin is great for me so far! However it only works properly in testing or debugging mode, not live mode, when used with firefox (and maybe other browsers… seemed to work in IE tho). The problem in live mode is that even when logged in, the user still sees the page as if they werent logged in. Any ideas what it doesnt recognize login in Live mode w/ firefox? Thanks!

Offline

#53 2009-06-29 20:38:58

ruud
Developer Emeritus
From: a galaxy far far away
Registered: 2006-06-04
Posts: 5,068
Website

Re: rvm_privileged v0.4

@lothar, I can’t reproduce that. It works fine for me in live mode using TXP 4.0.8.
Did you try refreshing the page using CTRL+F5?

Offline

#54 2009-06-29 21:06:54

lothar99
Member
Registered: 2009-03-20
Posts: 35

Re: rvm_privileged v0.4

Actually I think control F5 does fix it. I know the cache works diff btwn debug+test modes and live modes so that makes sense. But I don’t want my members to have to clear cache to view the page. Is there a way around that? Thanks!

Offline

#55 2009-06-29 21:11:04

ruud
Developer Emeritus
From: a galaxy far far away
Registered: 2006-06-04
Posts: 5,068
Website

Re: rvm_privileged v0.4

In the advanced preferences, you could switch the “Send “Last-Modified” header?” setting to NO, but keep an eye on bandwidth usage if you do that.

Offline

#56 2009-06-29 21:28:16

lothar99
Member
Registered: 2009-03-20
Posts: 35

Re: rvm_privileged v0.4

Hmm, thanks! I only need it not to cache in a portion of my website so I might try to get a no cache header, but apparently FF has problems with that. Maybe there is a workaround. Thanks for your help! Great plugin

Offline

#57 2009-11-23 05:06:52

iblastoff
Plugin Author
From: Toronto
Registered: 2006-06-11
Posts: 1,197
Website

Re: rvm_privileged v0.4

strange…

i am also getting the “you are not logged in” issue with firefox (3.5.5) despite how many times i reload. i have turned off “send last modified header” as well. when running safari, it is recognized as logged in just fine. using txp 4.2.0 and 0.4 of rvm_privileged.

Offline

#58 2010-12-29 23:53:36

imd
Member
From: Finland
Registered: 2010-12-13
Posts: 15
Website

Re: rvm_privileged v0.4

iblastoff wrote:

strange…
i am also getting the “you are not logged in” issue with firefox (3.5.5) despite how many times i reload. i have turned off “send last modified header” as well. when running safari, it is recognized as logged in just fine. using txp 4.2.0 and 0.4 of rvm_privileged.

I double this. Works in IE8 but refuse to work in FF 3.5.8 on my machine.

In debug mode I see: [<txp:rvm_if_privileged>: false] while I am logged in. Tried under different accounts, tried clearing cache — no effect in FF.

Any hint? I will try to check with other FF versions. Suddenly it works in IE on the same machine, thus something FF —> Textpattern specific.

Offline

#59 2010-12-30 00:49:34

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,286

Re: rvm_privileged v0.4

If my memory is correct, all I did to get in sync with the actual status was logging out and back in again. Hope that’s sufficient!


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#60 2010-12-30 01:07:23

imd
Member
From: Finland
Registered: 2010-12-13
Posts: 15
Website

Re: rvm_privileged v0.4

uli wrote:

If my memory is correct, all I did to get in sync with the actual status was logging out and back in again. Hope that’s sufficient!

Nope. Neither cleaning cache/cookies/etc., closing the browser and opening again, nor creating a new user account. FF 3.5 still does not pick up me as logged in user :(

Offline

Board footer

Powered by FluxBB