Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1105 2011-10-11 10:55:11

[Axel]
Member
From: Switzerland/Denmark
Registered: 2007-07-26
Posts: 65
Website

Re: zem_contact_reborn 4.0.3.20

You need to enable/install the zem_contact_lang plugin to get rid of the error.


Greetz [Axel]

Offline

#1106 2011-10-11 12:12:37

wolfcry911
Member
From: MA, USA
Registered: 2006-06-30
Posts: 51

Re: zem_contact_reborn 4.0.3.20

zem_contact_lang is already installed and enabled

edit// I just deleted and re-installed zem_contact_lang to no effect – the two errors remain

switching to debug mode gives the following:

A problem occured while loading the plugin: zem_contact_reborn -> Warning: Please contact support about failure on line 653

textpattern/lib/txplib_misc.php:653 load_plugins()
textpattern/publish.php:118 load_plugins()
index.php:44 include()

The above errors were caused by the plugin:zem_contact_reborn

A problem occured while loading the plugin: pap_contact_cleaner -> Warning: Please contact support about failure on line 653

textpattern/lib/txplib_misc.php:653 load_plugins()
textpattern/publish.php:118 load_plugins()
index.php:44 include()

The above errors were caused by the plugin:pap_contact_cleaner

Last edited by wolfcry911 (2011-10-11 12:37:08)

Offline

#1107 2011-10-11 12:50:03

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 8,858
Website GitHub Twitter

Re: zem_contact_reborn 4.0.3.20

did you try disabling pap_contact_cleaner?


Yiannis
——————————
neme.org | hblack.net | EMAP | NeMe @ github
I do my best editing after I click on the submit button.

Offline

#1108 2011-10-11 13:09:28

[Axel]
Member
From: Switzerland/Denmark
Registered: 2007-07-26
Posts: 65
Website

Re: zem_contact_reborn 4.0.3.20

Both plugins work together (I tried it) I only get the error if I disable zem_contact_lang. Are you using the latest version of zem_contact_lang? Try reinstalling zem_contact_reborn.


Greetz [Axel]

Offline

#1109 2011-10-11 20:11:44

wolfcry911
Member
From: MA, USA
Registered: 2006-06-30
Posts: 51

Re: zem_contact_reborn 4.0.3.20

I’ve now deleted and reinstalled all three plugins using the most current version (which I believe I had before anyway).
I get the same errors. I’m sure they work together as I have other sites with the same combination. I’ve even disabled all other plugins but these three and still receive the error – I’m baffled.

colak, yes I tried disabling pap_contact_cleaner which clears that error but the zem_contact_reborn error continues.

Last edited by wolfcry911 (2011-10-11 20:25:10)

Offline

#1110 2011-10-12 01:15:37

wolfcry911
Member
From: MA, USA
Registered: 2006-06-30
Posts: 51

Re: zem_contact_reborn 4.0.3.20

I just found a thread by someone with a similar problem with the same host. Apparently they’re running a module called strainer which blocks some PHP functions. I’ll contact my host and hopefully post a resolution soon.

Edit// Confirmed – it was a module the host (A2hosting.com) was using. They disabled it and now everything is running normal. Thanks for your help.

Last edited by wolfcry911 (2011-10-12 11:54:08)

Offline

#1111 2011-10-18 22:21:53

dreamer
Member
Registered: 2007-06-08
Posts: 242

Re: zem_contact_reborn 4.0.3.20

I can’t send the form through. I get this message;

Sorry, unable to send email.

Apparently, it will go through because the email it is to be sent to is using the same domain the site is hosted on. But if I use an email address seperate from the domain (ie; gmail, or yahoo), then it works.

Anyway to remedy this issue?

Offline

#1112 2011-10-20 09:39:46

ruud
Developer Emeritus
From: a galaxy far far away
Registered: 2006-06-04
Posts: 5,068
Website

Re: zem_contact_reborn 4.0.3.20

^^ check mail server logs for errors.

Offline

#1113 2011-11-23 11:15:33

wornout
Member
From: Italy
Registered: 2009-01-20
Posts: 256
Website

Re: zem_contact_reborn 4.0.3.20

Trying to send a form, after displaying errors, send button search for favicon.ico like this:

http://www.domain.it/section/favicon.ico#zcrf13d4e0e75c9480f2d1855840b5c4820

I’ve got the same behaviour with the full url to the article.
I’m using MLP and Textpattern 4.4.1

How can I solve it?

Offline

#1114 2011-11-24 18:34:08

ruud
Developer Emeritus
From: a galaxy far far away
Registered: 2006-06-04
Posts: 5,068
Website

Re: zem_contact_reborn 4.0.3.20

I’m not sure how favicon.ico got in there, but I’m pretty sure ZCR doesn’t do that. If the favicon.ico is somehow references elsewhere in your template, you may want to ask in the MLP topic.

Offline

#1115 2011-12-01 23:01:37

aslsw66
Member
From: Canberra, Australia
Registered: 2004-08-04
Posts: 342
Website

Re: zem_contact_reborn 4.0.3.20

I have modified zem_contact_reborn to do a few of things:

  • added some attributes to the fields to either show or not show the label. This is intended to allow you a little bit more control over how the email appears,
  • added some attributes to the fields to either show or not show the field contents. This is mainly to prevent the subject field appearing both in the subject line of the email and in the body,
  • added bcc and bcc_form attributes to allow you to send emails to number of people without disclosing the addresses of all of the recipients. This functionality overrides any to or to_form attributes ie. you have to choose whether you want a to or a bcc.

For testing purposes, I have created email accounts at Hotmail and Yahoo. I notice that the messages sent to the Hotmail account are flagged as junk immediately (until I identify them as not junk – after that everything works fine); Yahoo seems to be happier.

Are there any tips I need to take into account in terms of forming the headers to ensure that, as much as possible, these emails are not flagged as junk/spam/etc? I’m no programmer, so I would be grateful for any tips or ideas.

Once I have incorporated any ideas, I will release this for anyone interested to have a play with and tell me where I have gone wrong. It’s my first real attempt to work on a plug-in (of course, it’s easier to stand on the shoulder of giants that start from a blank page).

Future intentions are to develop an email template with replacement tags (like Bloke uses) so that there is more capacity yet again to customise the emails.

Offline

#1116 2011-12-01 23:20:20

maniqui
Member
From: Buenos Aires, Argentina
Registered: 2004-10-10
Posts: 3,070
Website

Re: zem_contact_reborn 4.0.3.20

Are there any tips I need to take into account in terms of forming the headers to ensure that, as much as possible, these emails are not flagged as junk/spam/etc? I’m no programmer, so I would be grateful for any tips or ideas.

Check the headers in the received email. Usually, there is link/option to “show original format. There may be some clues there on why it was flagged as junk. Maybe something related to SPF records. Let’s start there :)


La música ideas portará y siempre continuará

TXP Builders – finely-crafted code, design and txp

Offline

Board footer

Powered by FluxBB