Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1621 2019-11-17 07:32:05

jakob
Admin
From: Germany
Registered: 2005-01-20
Posts: 3,579
Website

Re: zem_contact_reborn 4.0.3.20

Your update woes might be related to another problem. Sometimes the update-routine got interrupted before it was completed. Some fixes were made but I can’t remember if they made it to the main 4.7.3 branch. You might want to try swapping out the “/textpattern/update” folder with the folder from the dev branch. As always make sure you have a backup of everything first in case you need to start over.

Regarding the plugins:

  • adi_contact – I believe this still works but has not been updated for com_connect. It could well work with some edits with com_connect (it has different callback names but AFAIK they are straight equivalents).
  • adi_variables – This should still work. Or you can simply update your own form with variables via Presentations › Forms.
  • bot_privs -> Replace with rah_privileges. While Jukka was away, I kept an updated version of that here. Since then Jukka has updated his here, though differently to mine. Usually only needed if you have multiple site authors with different access rights.
  • cbs_category_list -> txp:category_list can do almost everything the plugin could except for the article count per category.
  • ebl-image-edit – I don’t know of a replacement for this. There was Aviary for Textpattern but I believe that service no longer exists now.
  • ebl_write_page_email – That was a tag builder for email tags/links? There’s txp:email and yab_email for obfuscated email links or you simply write your mailto link in textile. If the plugin didn’t have a tag of its own, you can remove it as it is unlikely to be compatible with current admin area.
  • rvm_if_this_article -> replace with txp:if_article_id, e.g. <txp:if_article_id> class="active"</txp:if_article_id>…. If you have another use case, see the examples in the docs.
  • upm_image -> use the built-in txp:images and txp:image tags.
  • wet_native – setting per-user admin languages. This now works out of the box.
  • zem_contact / zem_contact reborn -> com_connect and pap_comconnect

Good luck!


TXP Builders – finely-crafted code, design and txp

Offline

#1622 2019-11-17 07:40:27

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 7,364
Website

Re: zem_contact_reborn 4.0.3.20

  • adi_contact – not needed. use this one for spam prevention
  • adi_variables (compatible to up to txp 4.6)
  • bot_privs – not compatible i think
  • cbs_category_list (can be achieved using native tags)
  • ebl-image-edit – Not compatible I think
  • ebl_write_page_email – Not compatible I think
  • rvm_if_this_article (can be achieved using native tags)
  • upm_image – not compatible, use native tags
  • wet_native – not needed, it is now in the core
  • zem_contact_lang – not needed
  • zem_contact_reborn – replace with com_coonect

Julian was faster:)

Last edited by colak (2019-11-17 07:42:00)


Yiannis
——————————
neme.org | hblack.net | LABS | State Machines | Respbublika! | NeMe @ github

Online

#1623 2019-11-18 01:38:56

bici
Member
From: vancouver
Registered: 2004-02-24
Posts: 1,526
Website

Re: zem_contact_reborn 4.0.3.20

jakob and colak
thanks to you i have now updated to 4.7.3.

i decided to disable and delete plugins as per yr suggestions. After the update i installed the new com_connect plugin. I then updated the tags in my contact_form, and after verifying all was working i deleted ALL the old plugins.

I have not been able to style via css the com_connect output but i can live with it. (i would have liked at the very least to output into my main div style but that proved fruitless)

Perhaps the plugin could use some guidelines in the documentation on applying css styles.

lesson learned : Don’t wait too long after an update to TXP has been released to istall it to my website.


…. texted postive

Offline

#1624 2019-11-18 01:56:49

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 1,746
Website

Re: zem_contact_reborn 4.0.3.20

bici wrote #320106:

After the update i installed the new com_connect plugin. I then updated the tags in my contact_form, and after verifying all was working i deleted ALL the old plugins.

I have not been able to style via css the com_connect output but i can live with it. (i would have liked at the very least to output into my main div style but that proved fruitless)

Perhaps the plugin could use some guidelines in the documentation on applying css styles.

oh, but it is documented by default each element has a class starting with com, and you can used custom names of course with/through the class attribute (just like you could do with zen_contact_reborn). Look under “tags“ and “styling“ in the help file for some info and guidance.

(i would have liked at the very least to output into my main div style but that proved fruitless)

we would need a bit more details to help out there… :-)

Offline

#1625 2019-11-18 04:37:10

bici
Member
From: vancouver
Registered: 2004-02-24
Posts: 1,526
Website

Re: zem_contact_reborn 4.0.3.20

hmmm.
with zem_conatct i had this in my css file:

  .zemContactForm fieldset {
   border: none;
   margin: 10px 0px 10px 0px;
	padding: 0px 0px 0px 0px;
   }
   .zemContactForm legend {
   padding: 0.5em 10px 0.5em 0;
   width: 60px;
   }

.zemContactForm label {
   float: left;
   width: 90px;
   margin: 0.3em 10px 0 0;
   text-align: right;
     padding: 2px 2px 5px 0;
   }
   .zemContactForm br {
   clear: left;
   }
   .zemContactForm .zemSubmit {
   /*margin: 9.5em 60px  0 70px; */
   margin: 0.5em 0 0 90px;
   }

i changed all those to .comConnectForm etc and it made no difference to the output.
there is no styling being applied.

added url of page website

Last edited by bici (2019-11-18 05:46:57)


…. texted postive

Offline

#1626 2019-11-18 06:01:30

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 1,746
Website

Re: zem_contact_reborn 4.0.3.20

Lovely… TYPO :-)

comCennectForm --> comConnectForm

(repeat 11 times, save).

Offline

#1627 2019-11-18 19:20:18

bici
Member
From: vancouver
Registered: 2004-02-24
Posts: 1,526
Website

Re: zem_contact_reborn 4.0.3.20

phiw13 wrote #320109:

Lovely… TYPO :-)

comCennectForm --> comConnectForm...

(repeat 11 times, save).

;-) !

made changes but no difference.
ps how does the form know to use css?

i currently have this in my contact_form :

<txp:com_connect to="no@email.tld"><p /> 
    <txp:com_connect_email /><p/>
    <txp:com_connect_text label="Telefono / Phone" min="7" max="15" /><p />
     <txp:com_connect_textarea cols="66" rows="6" label="domanda/ question" /><p>
<txp:com_connect_submit><strong>Invia/Send</strong> domanda</txp:com_connect_submit>
</txp:com_connect>

>Edit. deleted email

Last edited by colak (2019-11-19 05:03:39)


…. texted postive

Offline

#1628 2019-11-18 20:02:17

jakob
Admin
From: Germany
Registered: 2005-01-20
Posts: 3,579
Website

Re: zem_contact_reborn 4.0.3.20

Hi bici,

com_connect adds classes by default and you can see what they’re called here in the docs. The same class is added to the item and its label, so you may need to use label.comText and input.comText (and so on for the other tags) if you want to be more specific about what you’re styling.

What you probably need is just to add the attribute break="" as described here to stop it adding a br. Then you can style your labels to appear left of the fields but right-aligned.


TXP Builders – finely-crafted code, design and txp

Offline

#1629 2019-11-18 21:17:33

bici
Member
From: vancouver
Registered: 2004-02-24
Posts: 1,526
Website

Re: zem_contact_reborn 4.0.3.20

thank-you i am happy enough with it now.
But for one issue: Where is the control for the Title of the forrm “Contact” i would like it centred and in bold.


…. texted postive

Offline

#1630 2019-11-18 22:28:10

jakob
Admin
From: Germany
Registered: 2005-01-20
Posts: 3,579
Website

Re: zem_contact_reborn 4.0.3.20

bici wrote #320118:

Where is the control for the Title of the forrm “Contact” i would like it centred and in bold.

That’s the legend tag.

You have some mistyped HTML tags in your code above. Try this combination:

<txp:com_connect to="no@email.tld">
    <div class="form-item"><txp:com_connect_email break="" /></div>
    <div class="form-item"><txp:com_connect_text label="Telefono / Phone" min="7" max="15" break="" /></div>
    <div class="form-item"><txp:com_connect_textarea cols="66" rows="6" label="Domanda / Question" break="" /></div>
    <div class="form-submit"><txp:com_connect_submit><strong>Invia/Send</strong> domanda</txp:com_connect_submit></div>
</txp:com_connect>

and this css:

.comConnectForm legend {
    width: 100%;
    padding: 0.5em 0;
    text-align: center;
    font-weight: bold;
}
.comConnectForm label {
    float: left;
    width: 100px;
    margin: 0.3em 10px 0 0;
    text-align: right;
    padding: 2px 2px 5px 0;
}
.comConnectForm .form-item {
    clear: left;
    min-height: 3.5em;
}
.comConnectForm input.comEmail,
.comConnectForm input.comText,
.comConnectForm textarea.comTextarea {
    padding: 0.6em;
    border: 1px solid #999;
    font-family: inherit;
    font-size: 13px;
}
.comConnectForm input.comEmail,
.comConnectForm input.comText {
    width: 250px;
}
.comConnectForm .comTextarea {
    width: 400px;
}
.comConnectForm .comSubmit {
    margin: 1em 0 0 112px;
    padding: .4em;
}

That should get you nearer to what I think you want.


TXP Builders – finely-crafted code, design and txp

Offline

Board footer

Powered by FluxBB