Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#97 2009-04-27 06:08:21

wet
Developer Emeritus
From: Schoerfling, Austria
Registered: 2005-06-06
Posts: 3,275
Website

Re: wet_quicklink: Quick internal link builder

Enforce a “canonical URL”, and you’re set.

 RewriteCond %{HTTP_HOST} !^example\.com [NC]
 RewriteRule ^(.*)$ http://example.com/$1 [R=301,L]

Offline

#98 2009-04-27 06:28:54

RedFox
Member
From: Netherlands
Registered: 2005-03-25
Posts: 783
Website

Re: wet_quicklink: Quick internal link builder

Installing wet_quicklink v0.5 gives this error-message

A site build on Textpattern 4.0.8 …

Something to do with PHP config … !?

Thanks for any help!

Offline

#99 2009-04-27 06:54:08

saccade
Plugin Author
From: Neubeuern, Germany
Registered: 2004-11-05
Posts: 517

Re: wet_quicklink: Quick internal link builder

Thanks wet, for that quick answer.

But (maybe I’m wrong) it does work for the public-side but obviously doesn’t affect the admin-side.
On the admin-side the URL stays “domain.de/textpattern” if entered without www and stays “www.domain.de/textpattern” if entered with “www”. Odd.

Do I need to set the Rewrite explicitly in the textpattern subdirectory? (I did it in the domains root)

Or (please forgive that noobie-question) does one of those ReWrite-Rules I found here, better?

RewriteCond %{HTTP_HOST}//s%{HTTPS} ^www\.(.*)//((s)on|s.*)$ [NC]
RewriteRule ^ http%3://%1%{REQUEST_URI} [L,R=301]

(from Sitepoint mentioned here by masa)

RewriteCond %{HTTP_HOST} ^www\.domain\.com$ [NC]
RewriteRule ^(.*)$ http://domain.com/$1 [R=301,L]

(from jm im this forum)

RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
RewriteRule ^(.*)$ http://%1/$1 [R=301,L] 

(from no-www.org)

Edit No, obviously they don’t, I have tested them. All that rewriting doesn’t take effect for subdirs (textpattern) and directly called phps (e.g. if I call www.domain.de/index.php no rewrite done).

Last edited by saccade (2009-04-27 07:04:50)

Offline

#100 2009-06-16 13:28:49

feytus
Member
Registered: 2009-06-02
Posts: 43

Re: wet_quicklink: Quick internal link builder

When using the permlink option with this (v. 0.5), nothing shows up on the atual article page. When using textile, it works though. But it would be nice to have all the internal links more flexible. Any suggestions? Here’s the page I’ve been trying to add the links to (under “releases” at the bottom):

http://www.marsmelons.com/artists/30/amor-fati

Last edited by feytus (2009-06-16 13:29:34)

Offline

#101 2009-06-16 16:48:31

wet
Developer Emeritus
From: Schoerfling, Austria
Registered: 2005-06-06
Posts: 3,275
Website

Re: wet_quicklink: Quick internal link builder

Please perform these steps and report back, at which stage you do not receive the expected result:

  1. Create a new article on the “Content > Write” tab
  2. Click inside the text area labelled “Body”
  3. Enter some body text
  4. Select / highlight (a portion of) the body text
  5. Click on the “Insert link” menu entry on the left
  6. Select the “txp:permlink” entry on the “Permanent link mode” drop-down
  7. Click on any article’s title from the QuickLink list
  8. What’s the content of the article’s body now?

Offline

#102 2009-06-18 14:44:04

feytus
Member
Registered: 2009-06-02
Posts: 43

Re: wet_quicklink: Quick internal link builder

That worked a treat – I’d just forgotten to put any text to actually show the link. :p Thanks, man!

Offline

#103 2009-08-11 05:06:45

RedFox
Member
From: Netherlands
Registered: 2005-03-25
Posts: 783
Website

Re: wet_quicklink: Quick internal link builder

No ‘Insert Link’ on the Write page (TXP 4.0.8 ) … all plug-ins installed and working! Tried all suggestions in this thread; no effort. An .xml output of wet_peex search you can find here … any help is welcome … :)

Offline

#104 2009-08-11 05:52:36

wet
Developer Emeritus
From: Schoerfling, Austria
Registered: 2005-06-06
Posts: 3,275
Website

Re: wet_quicklink: Quick internal link builder

I see the error message, but can’t think of a reason for it to occur. Being granted admin access would eventually help…

Offline

#105 2009-08-18 10:59:56

tennapel
Member
Registered: 2009-05-31
Posts: 62

Re: wet_quicklink: Quick internal link builder

I have installed wet_quicklink on my local textpattern installation on my Mac (Leopard, with the apple delivered apache+php and mysql install).

It did work, but out of the blue, the ‘insert link’ option in the admin panel for writing new content has disappeared. The plugins were not changed and still active. I have deinstalled the plugins and reinstalled them, but I can’t get them to work anymore. No error messages on installing or activating.

I have tried several browsers (Camin0 1.6.8, safari 4, Firefox 3.5) to make sure there is not some javascript blocker at work, but in every browser the same result.

Any idea where to look, what to try or how to debug to find out what is happening?

The plugins still work on the production machine, a hosted website running on a Linux install I pressume.

Offline

#106 2009-08-18 11:17:11

wet
Developer Emeritus
From: Schoerfling, Austria
Registered: 2005-06-06
Posts: 3,275
Website

Re: wet_quicklink: Quick internal link builder

Try to browse to http://localhost/<sub-dir>/textpattern/index.php?wet_rsrc=quicklink_js&v=0.5 or whatever your local host entry is. You should see regular Javascript. Then return to the “Write” screen, as sometimes the sole act of visiting the script brings browsers back on track.

Offline

#107 2009-08-18 19:03:14

tennapel
Member
Registered: 2009-05-31
Posts: 62

Re: wet_quicklink: Quick internal link builder

Your comment made me inspect url’s a bit better. It has got something to do with the url you logged in to and the sitepath stored in the database.

Let me try to explain: You can approach a Mac in a network using its ‘rendez-vous’ adres, something like http://<machinename>.local/ This produces the same results as localhost on your machine.

However, if you have a site_url in your preferences that start with http://locahost and you work on textpattern install from another machine in the network, any permlink will start with http://localhost and this will force the browser on the remote machine to look for its own localhost.

If you want to test textpattern on a local install in your local network from a remote machien, you have either to make a virtual host in apache, or if you are a lazy Mac user like me, you just type the rendez-vous adress into the preferences and all is well.

However, if you work on the same machine the textpattern install is running, and you have a local bookmark in your browser to log in Textpattern starting with http://localhost, the session or cookie or whatever is used will use the ‘localhost’ domain, while every link in Textpattern starts with the rendez-vous address.

So, with a few click, your URL starts will turn from http://localhost to http://<machinename>.local and that’s when the link disappears in the admin/write panel. When I changed the URL and refreshed, the link reappears.

I think this is a very specific Mac-only, local network, log-in problem, if and only if you have administered the rendez-vous address as the site_url in your prerences.

And you won’t want to know how long it took me before I realised what was going on, with the link appearing and disappearing :-) And if you don’t understand any of what I’m writing I can empathize, I hardly do myself.

Offline

#108 2009-09-15 07:52:07

jstubbs
Moderator
From: Hong Kong
Registered: 2004-12-13
Posts: 2,395
Website

Re: wet_quicklink: Quick internal link builder

Mmm. Not sure why, but notice wet_quicklink 0.5 has disappeared from my TXP Tips install. Have wet_peex 0.4 too. Running a multi sites install of 4.2.

Odd, because I see some #quicklink styles in the view source. Checked its not a theme issue by changing all the themes but no cigar.

Ideas?

Offline

Board footer

Powered by FluxBB