Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#205 2007-06-09 11:57:35

Pat64
Plugin Author
From: France
Registered: 2005-12-12
Posts: 1,531
GitHub Twitter

Re: zem_contact_reborn 4.0.3.19 (old version)

Tks lot ruud.
As always : an efficent and quickly answer!

Regards,


Patrick.

Github | CodePen | Codier | Simplr theme | Wait Me: a maintenance theme | [\a mi.ni.ma]: a “Low Tech” simple Blog theme.

Offline

#206 2007-06-09 14:50:39

ruud
Developer Emeritus
From: a galaxy far far away
Registered: 2006-06-04
Posts: 5,068
Website

Re: zem_contact_reborn 4.0.3.19 (old version)

evalottchen and uli, try installing the compressed version of the zem_contact_reborn plugin. The plugin itself is exactly the same, but the code you have to copy/paste is much smaller (19kB instead of 78kB).

Offline

#207 2007-06-09 14:57:06

sthmtc
Member
From: CGN, GER
Registered: 2005-01-17
Posts: 586
Website

Re: zem_contact_reborn 4.0.3.19 (old version)

ruud wrote:

evalottchen and uli, try installing the compressed version of the zem_contact_reborn plugin. The plugin itself is exactly the same, but the code you have to copy/paste is much smaller (19kB instead of 78kB).

plugin is installing fine now (i was having the same issues as uli using hosteurope)

Offline

#208 2007-06-09 16:38:15

alexandra
Member
From: Cologne, Germany
Registered: 2004-04-02
Posts: 1,370

Re: zem_contact_reborn 4.0.3.19 (old version)

Hi ruud,
i have a weird problem with zem_contact_reborn. I have this:

<txp:zem_contact to="post(a)kbbu.de" form="kontakt" label="" thanks_form="kontaktDanke" />

on the page. (of course the (a) is an @)

In form=kontakt i have:

<txp:zem_contact_text label="Ihr Name:" />
<txp:zem_contact_email />
<txp:zem_contact_text label="Betreff:" />
<txp:zem_contact_textarea label="Ihre Mitteilung:" />
<txp:zem_contact_submit label="Senden" />

Now only one email is sent back to the sender and none to the siteowner (here post(a)kbbu.de)

The site in question is -> here

Any idea?

(Congrats on joining the dev Team :)

Last edited by alexandra (2007-06-09 17:35:19)

Offline

#209 2007-06-09 18:46:45

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,286

Re: zem_contact_reborn 4.0.3.19 (old version)

Thank you, ruud!
I always wonder how a compaction rate like this is possible and yet can be read by txp.


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#210 2007-06-09 20:09:24

ruud
Developer Emeritus
From: a galaxy far far away
Registered: 2006-06-04
Posts: 5,068
Website

Re: zem_contact_reborn 4.0.3.19 (old version)

alexandra, the copysender=1 attribute is missing in your zem_contact tag (if you want the sender to get a copy). I tried submitting something in that contact form, but didn’t get anything sent to the email address I entered. Makes sense, without a copysender attribute, but it’s not what you experienced… strange.

uli, apparently TXP supports compressed plugins (using gzip, text compresses to around 20% of original size), but it wasn’t until I had a closer look at the code that deals with plugins in TXP that I noticed this. By default I’m not compressing, because I’m not sure if everyone has the zlib option compiled into PHP.

Last edited by ruud (2007-06-09 20:27:17)

Offline

#211 2007-06-12 08:13:38

DarkEol
New Member
Registered: 2007-06-12
Posts: 2

Re: zem_contact_reborn 4.0.3.19 (old version)

zem_contact_lang 4.0.3.6:
“If you have a dual-language site and the languages use separate “sections”, you can use the tag to enable different translations. An example of this usage is shown in the “forum thread”:http://forum.textpattern.com/viewtopic.php?id=13416. Our thanks to Els (doggiez) for this example.”

This thread doesn’t exist. So where I can see example of using different translations?

Offline

#212 2007-06-12 08:19:52

ruud
Developer Emeritus
From: a galaxy far far away
Registered: 2006-06-04
Posts: 5,068
Website

Re: zem_contact_reborn 4.0.3.19 (old version)

Offline

#213 2007-06-12 08:38:42

DarkEol
New Member
Registered: 2007-06-12
Posts: 2

Re: zem_contact_reborn 4.0.3.19 (old version)

Oooops… Thanks :-)

P.S. When I logged in I can see it. Otherwise forum answers: “Bad request. The link you followed is incorrect or outdated.”

Last edited by DarkEol (2007-06-12 08:44:06)

Offline

#214 2007-06-14 15:58:18

vittorio
Member
From: Roma caput mundi
Registered: 2006-02-01
Posts: 122
Website

Re: zem_contact_reborn 4.0.3.19 (old version)

Hi all, here’s my question:
how can I make this wonderful plugin to always send the article excerpt AND the body? Last version sends only the excerpt if it is present, how can i disable this function?

Thanks to everyone

Edit. Other question: is there a way to avoid html entities to be shown in the email containing the article? I think it is caused by the tiny_mce editor, which I use, how can i fix it?

Last edited by vittorio (2007-06-14 16:03:26)


Happily served with Txp: Strampelli.net, Brain Essence, NicolaTranfaglia.com

Offline

#215 2007-06-14 19:41:27

ruud
Developer Emeritus
From: a galaxy far far away
Registered: 2006-06-04
Posts: 5,068
Website

Re: zem_contact_reborn 4.0.3.19 (old version)

In tiny_mce.js there is a configuration option “entity_encoding” that must be changed to “raw” to avoid unnecessary html entities.

To get both body and excerpt in the email, edit the plugin and change this line (around 15% from the top, around line 150, I think):

$msg[] = trim(strip_tags(str_replace($s_ar,$r_ar,(trim(strip_tags($thisarticle['excerpt'])) ? $thisarticle['excerpt'] : $thisarticle['body']))));

into:

$msg[] = trim(strip_tags(str_replace($s_ar,$r_ar,$thisarticle['excerpt'].$thisarticle['body'])));

Last edited by ruud (2007-06-22 17:28:59)

Offline

#216 2007-06-14 20:40:47

WebKat
Member
Registered: 2007-01-16
Posts: 301

Re: zem_contact_reborn 4.0.3.19 (old version)

Can someone tell me what I need to do to change the style of the legend border? Do I need to set a class in my form? Is there already a class I can just change in my css? (And do I need to use the legend tag itself? Right now I’m letting it do its thing automatically)



WebKat

Offline

Board footer

Powered by FluxBB