Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

  1. Index
  2. » Plugin support
  3. » smd_slimbox

#445 2008-04-04 10:22:33

sisushka
Member
Registered: 2007-07-30
Posts: 14

Re: smd_slimbox

Does smd_slimbox work with messy URLs?
Is it possible that messy URLs are the reason why the script does not load? Thumbnails actually do load but when I click any of them, nothing happens. I was trying really hard to figure it out but with no success so far.
I’m using TXP 4.0.5, smd_slimbox 0.26. I have included smd_slimbox_inc.
I’m desperate.

EDTI: I’ve updated and went for smd_slimbox3. It’s solved the problem :)

Last edited by sisushka (2008-04-04 11:22:21)

Offline

#446 2008-04-04 11:33:28

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,629
Website GitHub

Re: smd_slimbox

sisushka wrote:

I’ve updated and went for smd_slimbox3. It’s solved the problem :)

Phew! Thank goodness, because I couldn’t solve your original problem ;-) I thought it worked with messy URLs, but I must admit I’ve never tried it. Mind you, v0.26 had a few issues so it may just have been that. Glad you got it sorted with the latest version.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#447 2008-04-04 13:07:56

sisushka
Member
Registered: 2007-07-30
Posts: 14

Re: smd_slimbox

Bloke wrote:

Phew! Thank goodness, because I couldn’t solve your original problem ;-) I thought it worked with messy URLs, but I must admit I’ve never tried it. Mind you, v0.26 had a few issues so it may just have been that. Glad you got it sorted with the latest version.

Thanks for latest version, it is literally puuuuuuuurfect :-) However, there’s one little problem that makes wrinkles on my face – I still haven’t figured out how to add class atribute to thumbnail links. I’m using Thickbox.
I’d be glad for any ideas :-)

Last edited by sisushka (2008-04-04 13:08:25)

Offline

#448 2008-04-04 13:49:27

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,629
Website GitHub

Re: smd_slimbox

sisushka wrote:

I still haven’t figured out how to add class atribute to thumbnail links. I’m using Thickbox.

Does adding linkclass="thickbox" work?


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#449 2008-04-04 13:53:34

sisushka
Member
Registered: 2007-07-30
Posts: 14

Re: smd_slimbox

Bloke wrote:

Does adding linkclass="thickbox" work?

Oh yes, it does, I probably didn’t read the documentation properly… Thank you! You’ve just saved a whole bunch of my nerve cells :D

Offline

#450 2008-04-06 20:20:51

keith
Member
From: Blyth, Northumberland, England
Registered: 2004-12-08
Posts: 199
Website

Re: smd_slimbox

Hi Stef,

Nothing’s ever simple, is it?

Pending reworking my site to use smd_gallery I’ve just updated smd_slimbox to 0.3 (and smd_lib to 0.32) – and the script has stopped working..!

I use it in a very straightforward way – <txp:smd_slimbox category="blyth-harbour-7-december-2007" /> – and don’t have glz_custom_fields installed (if that matters), so I’m a bit stumped.

Now, instead of the expected result, clicking on a thumbnail simply takes me to the full-sized image. This is true in Opera, FF and IE.

It was working immediately before I updated and I’ve made no other changes. I’ve tried reinstalling, deleting then reinstalling – no joy.

Bummer, as they say!

Last edited by keith (2008-04-06 20:23:10)


Keith
Blyth, Northumberland, England
Capture The Moment

Offline

#451 2008-04-06 20:38:02

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,629
Website GitHub

Re: smd_slimbox

keith wrote:

Now, instead of the expected result, clicking on a thumbnail simply takes me to the full-sized image.

Right, the reason is that since I removed smd_slimbox_inc you now have to include the slimbox scripts yourself on the page. See, smd_slimbox_inc used to handle all the script side of things for you and, while it was a noble idea (I thought) in the beginning, it wasn’t The TXP Way TM and kind of irked quite a few people who wanted to take the slimbox concept up a level. Not to mention it required hacks to make the thumbs into an RSS feed and so forth.

So, in response to the (I think virtually unanimous) response from my poll on the subject I dropped it. What you now need to do is add the scripts manually somewhere in your page <head>. If you have the scripts uploaded in the same place as they were in older versions of smd_slimbox you’d add this:

<script type="text/javascript" src="/js/mootools.js"></script>
<script type="text/javascript" src="/js/slimbox.js"></script>
<link rel="stylesheet" type="text/css" media="screen" href="/css/slimbox.css" />

Give that a whirl and the effect should return.

Sorry about the hassle it caused you; perhaps my docs weren’t clear enough, I’ll review them!


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#452 2008-04-06 21:09:54

keith
Member
From: Blyth, Northumberland, England
Registered: 2004-12-08
Posts: 199
Website

Re: smd_slimbox

There ya go!

I’d noted the removal of smd_slimbox_inc but hadn’t actually realised what that would mean in real terms (I’d completely forgotten its usage), and – in Opera – I didn’t get a warning message for using it either.

Not that I care – things are back to normal, for which many thanks.

It might be of interest to others that (same as when I installed smd_slimbox originally) I needed to include “/tp/” in the paths to the scripts and CSS, as in "...src="/tp/js/slimbox.js"></script>"

Thanks again for the fine work and even better support!

Last edited by keith (2008-04-06 21:12:51)


Keith
Blyth, Northumberland, England
Capture The Moment

Offline

#453 2008-04-08 03:47:47

fangonk
Member
Registered: 2007-07-12
Posts: 44

Re: smd_slimbox

Hey, I love this new update. Im working on getting thickbox to work. Ive linked all the necessary libraries in the head section but I just can’t seem to get it to initiate yet. I feel as if Im probably missing something simple:

<txp:smd_slimbox imageid=”?article_image” showpagelinks=“0” linkclass=“thickbox”/>

Any thoughts?

Offline

#454 2008-04-08 08:14:06

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,629
Website GitHub

Re: smd_slimbox

fangonk wrote:

I feel as if Im probably missing something simple

Hmm, well if you are missing something, I certainly can’t spot it. Your tag is perfect. Do the thumbs show up ok? Is it just the thickbox effect that doesn’t fire?

I tried your exact tag in an article, listed a few image IDs in the article_image and made sure this was in the <head>:

<script type="text/javascript" src="/textpattern/jquery.js"></script>
<script type="text/javascript" src="/scripts/thickbox.pack.js"></script>
<link rel="stylesheet" type="text/css" href="/css/thickbox.css" />

It brought up thickbox ok. However, if I added mootools.js or slimbox.js to the page, it broke: I got some random js errors. Perhaps check you don’t have any other libraries on your page and work up from there? Also, see if you have any js errors in Firebug that might guide you. If you do have both, the libraries are supposed to be able to work side by side; maybe the page just needs the jQuery.noconflict() in order to work.

If none of that helps, do you have a URL you could share?


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#455 2008-04-08 08:49:00

fangonk
Member
Registered: 2007-07-12
Posts: 44

Re: smd_slimbox

its just the thickbox which isn’t firing. Here is some sample content I have uploaded for testing purposes: http://richardmagness.com/articles/pigeon-burn/?p=11
The large image at the top should fire off the thickbox but it goes straight to the full-size. I’ve double-checked the head, to make sure all the scripts have been linked correctly. The plugin seems to be correctly wrapping the image with the thickbox class as well.

Offline

#456 2008-04-08 09:48:24

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,629
Website GitHub

Re: smd_slimbox

fangonk wrote:

its just the thickbox which isn’t firing.

Looks like a missing double-quote at the end of your src attribute for thickbox.js, and perhaps a bogus “smart” curly quote character on the thickbox.css rel attribute line beneath it?

Wicked graphics, btw.

Last edited by Bloke (2008-04-08 09:48:50)


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

  1. Index
  2. » Plugin support
  3. » smd_slimbox

Board footer

Powered by FluxBB