Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#2461 2017-10-21 10:49:45

spiridon
Member
From: Mariupol, Ukraine
Registered: 2011-01-30
Posts: 43
Website

Re: MLP - The Multi-Lingual Publishing Pack

Done. Download from here

Last edited by spiridon (2017-10-21 10:50:06)

Offline

#2462 2017-10-23 21:38:29

Bloke
Developer
From: Leeds, UK
Registered: 2006-01-29
Posts: 10,578
Website GitHub

Re: MLP - The Multi-Lingual Publishing Pack

spiridon wrote #307494:

Done. Download from here

Awesome, thank you.


The smd plugin menagerie — for when you need one more gribble of power from Textpattern. Bleeding-edge code available on GitHub.

Txp Builders – finely-crafted code, design and Txp

Offline

#2463 2017-10-25 08:52:23

demoncleaner
Plugin Author
From: Germany
Registered: 2008-06-29
Posts: 190
Website

Re: MLP - The Multi-Lingual Publishing Pack

Wow great! Thanks a lot.

Would fixing the toggle option on each article be done on lib/l10n_admin_classes.php, too?
Sorry, I misunderstood the toggle function in the articles view. Always thought it is for switching to the same article in the other language. But it seems it is not now that I checked lib/l10n_admin.php. But I think the toggle is still not working. Even though the text direction is not important for me perosnally.

But wouldn´t it be cool to have a feature like I mentioned? A selectbox where I could choose to jump directly to the linked article in the chosen language? I think I am going to try something. Because on cloned renditions we already have the base ID shown on top, that should be doable.

Last edited by demoncleaner (2017-10-25 09:07:39)

Offline

#2464 2017-10-25 11:24:50

demoncleaner
Plugin Author
From: Germany
Registered: 2008-06-29
Posts: 190
Website

Re: MLP - The Multi-Lingual Publishing Pack

I am struggeling a bit having my MLP driven site doing what I want it to do in terms of SEO and URLs.
I was wondering why in the sections with MLP installed I would have the option to have a section title for each language but not a description field for every language.
For providing the meta data via sections that would need to be also multilingual or am I missing something?

Has anyone had a good idea yet on having the URLs in the current language as well.
So that if the actual sections name (on a german/english website) is “kontakt” it would give us www.domain.com/en/contact instead of www.domain.com/en/kontakt

Offline

#2465 2017-11-17 12:45:11

giampablo
Member
From: Italy
Registered: 2008-07-17
Posts: 86
Website

Re: MLP - The Multi-Lingual Publishing Pack

I have a problem with the language switcher here:

tcaspa.com

If I am in an (Italian) article page (for instance this article), toggling to EN the switcher works.
But on switching back to IT I get a 404 page not found error, (and the language switcher disappears).
With a simple page refresh, I get the correct page.
In other words, the toggle switch is ok the first time, but not the second time (404 error).

Can anybody give me a hint and test the site?

Here is the tag:

<txp:l10n_lang_list list_class="contact-btn" display='short' surpress_current="1" wraptag="ul" break="li" />

Texpattern 4.5.7 – l10n plugin version 4.5.5-01

Also, please let me know, if you are not in Italy (i.e. in UK), which version of the site opens up (should be EN, right?).
And what if you are in another country? (i.e. not in UK or Italy.). I suppose EN, right?

Last edited by giampablo (2017-11-17 12:48:44)

Offline

#2466 2017-11-17 18:02:29

els
Moderator
From: The Netherlands
Registered: 2004-06-06
Posts: 7,458

Re: MLP - The Multi-Lingual Publishing Pack

Hi Giampablo, your tag seems to be correct.
I’m in the Netherlands, and the EN version of the site opens up for me. Which is fine I guess.
The 404’s only seem to happen in the News (articoli) section. But I also noticed that on all pages switching from EN to IT works fine, but switching from IT to EN does change the url but does not change the content. Only after clicking EN in the menu for the second time (or refreshing the page) shows the english content. Which makes me wonder if it’s something of a caching issue?

Offline

#2467 2017-11-17 19:01:28

giampablo
Member
From: Italy
Registered: 2008-07-17
Posts: 86
Website

Re: MLP - The Multi-Lingual Publishing Pack

Hi Els, thanks for checking and glad to hear that in the Netherlands the EN version opens up, which is the desired behaviour. What you noticed is correct, the problem is more evident in the News section (due to 404’s) but concerns all pages. And caching seems to be the main issue.

Unfortunately I have no idea how to solve it.
If the issue is related to the hosting server maybe I should modify .htaccess?
And how? To me it’s a grey area…

Offline

#2468 2017-11-17 20:03:27

jakob
Admin
From: Germany
Registered: 2005-01-20
Posts: 4,198
Website

Re: MLP - The Multi-Lingual Publishing Pack

This is going to sound weird, and I can’t explain it, but opening your site from Germany shows me the Italian in Safari (Mac) and on an iOS device, but shows me English if I open your site in Firefox or Chrome ?! All browsers are localised to German. I’m wondering if some aren’t sending the correct language headers but I’m not sure how to check that.

I see the same thing als Els when switching to English – that “EN” needs to be clicked twice but not with “IT” when switching back.
How does MLP work? Does it set a cookie? If so, maybe the cookie change only happens on the page reload, but the cookie is checked at the beginning of the page before it has come into effect. Or maybe the cookie is removed and then reset. If Italian is always the fallback language, then you wouldn’t notice it “not working yet” when switching to Italian. But that’s just conjecture. I really don’t know how it works. Just an idea.


TXP Builders – finely-crafted code, design and txp

Offline

#2469 2017-11-18 07:52:22

bici
Member
From: vancouver
Registered: 2004-02-24
Posts: 1,881
Website

Re: MLP - The Multi-Lingual Publishing Pack

i opened your gorgeous site from here in canada. the default language was Italian.

http://www.tcaspa.com/

clicking on the EN switch brought me to http://www.tcaspa.com/en /


…. texted postive

Offline

#2470 2018-08-03 12:07:02

demoncleaner
Plugin Author
From: Germany
Registered: 2008-06-29
Posts: 190
Website

Re: MLP - The Multi-Lingual Publishing Pack

I am about to setup a multi language site on the latest textpattern version 4.7.1.
I was wondering if anybody played around already with MLP and 4.7.1 which I did and I ran into some problems.

First problem was that textpattern/lib/txplib_db.php had to adjusted which I think I did properly because after that all seemed to work fine. The problem that remains is now for whatever reason I cannot access to sections detail page and to Renditions page as soon as MLP is up and running.

So my question would be – as it seems MLP is still the only good way to have your textpattern site multilingual … has anybody running MLP on 4.7.1 yet? And if not who would be willing to help me get this going on 4.7.1 ?

Or is there yet any serious alternative to MLP that I am missing?

Last edited by demoncleaner (2018-08-03 12:07:19)

Offline

#2471 2018-08-06 10:28:40

spiridon
Member
From: Mariupol, Ukraine
Registered: 2011-01-30
Posts: 43
Website

Re: MLP - The Multi-Lingual Publishing Pack

I’ll try to adapt the plug-in to the new version. You’ll have to test.

Offline

#2472 2018-08-10 08:16:53

spiridon
Member
From: Mariupol, Ukraine
Registered: 2011-01-30
Posts: 43
Website

Re: MLP - The Multi-Lingual Publishing Pack

During Adapting MLP with Txp 4.7.1 I ran into a strange problem with languages. In 4.6.2 I have “uk-ua” and “ru-ru” language codes. But after upgrading to 4.7.1 I have “uk” and “ru” accordingly.

Logical integrity is broken because all articles, description in categories, images and etc are connected with old language codes.

What should I prefer to fix this situation? Return old codes of languages in txp_lang table or alter names of columns in accordingly tables and update codes in table textpattern.

Is it not a mistake? And willn’t Txp return to the old codes?

Offline

Board footer

Powered by FluxBB