Textpattern Forum

You are not logged in. Register | Login | Help

#1 2012-08-07 20:43:33

tester
Member
Registered: 2012-08-01
Posts: 10

VirtualHosts problem

I am trying to set up a multiple site configuration locally, and I guess I am having problems with my http-vhosts.conf file. I added the following into it:

<VirtualHost *:80>
ServerName localhost
DocumentRoot “/srv/httpd/htdocs/”
</VirtualHost>

<VirtualHost site1.prod:80>
ServerName site1.prod
ServerAlias www.site1.prod
DocumentRoot “/srv/httpd/htdocs/textpattern/sites/site1/public”
<Directory “/srv/httpd/htdocs/textpattern/sites/”>
Options +FollowSymLinks
</Directory>
</VirtualHost>

And I edited the http.conf file to uncomment the Include /etc/httpd/extra/http-vhosts.conf line.

But when I type site1.prod into the browser’s URL field it takes me online and tells me the site cannot be found. Am I supposed to set up another file? Or am I setting these up incorrectly?

And I did copy the directories correctly with symlinks and all. Am I supposed to do something to a hosts file?

Offline

#2 2012-08-07 20:52:01

net-carver
Member
From: UK
Registered: 2006-03-08
Posts: 1,648

Re: VirtualHosts problem

If you do a ping site1.prod from the command line, does it say “127.0.0.1”? If not, you probably need to add an entry to your local hosts file.


Steve
Textile | My plugins on GitHub | @netcarver

Offline

Board footer

Powered by FluxBB