Textpattern Forum

You are not logged in. Register | Login | Help

#1 2012-08-06 07:16:50

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 606
Website

[solved] Clean URL's on OS X Lion ?

I had a bad HD crash and needed to set up my whole environment again (::sigh::).
When setting up a new Textpattern install, the Diagnostics pane helpfully (::bleh) tells me that the clean url test fail. And yes, testing with the default site, any clean url format fails (404).

From the previous HD /environment, this was working fine however. I’ve gone through all my config files (httpd.conf, httpd-vhosts.conf, php.ini, hosts, etc) and compared to the old files rescued from Time Machine. I’ve absolutely no idea what is going wrong. All paths in TXP’s config.php file are correct, I use the default .htaccess file.
TXP svn build, r4046
Default Apache and PHP as shipped by OS X Lion.

Suggestions ?
Tia.

Last edited by phiw13 (2012-08-06 11:57:01)

Offline

#2 2012-08-06 09:08:53

philwareham
Core designer
From: Farnham, Surrey, UK
Registered: 2009-06-11
Posts: 1,595
Website

Re: [solved] Clean URL's on OS X Lion ?

Not really a direct solution, but I use MAMP on Mountain Lion and that works great. Since it installs it’s own versions of Apache, PHP etc I find I can control the environment a bit better than be relying on the OSX defaults.

Offline

#3 2012-08-06 12:03:57

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 606
Website

Re: [solved] Clean URL's on OS X Lion ?

I found a small error for the affected domain in my httpd-vhost.conf that caused the urls not to resolve. Once corrected, everything works ok. I suspect I spent too many hours in front of a monitor over the past 2 days.

philwareham wrote

… Mountain Lion …

::sigh:: no Mountain Lion on this MacPro. It is too old :-( (come on, 2006 isn’t that long ago). I’ll sure upgrade the other machines once the .1 release is out.

Offline

Board footer

Powered by FluxBB