Textpattern Forum

You are not logged in. Register | Login | Help

#71 2012-08-04 13:28:03

philwareham
Core designer
From: Farnham, Surrey, UK
Registered: 2009-06-11
Posts: 1,599
Website

Re: Feedback to: Textpattern 4.5.0 Beta released

@kevin

I’ll look into the focus states tomorrow, I’ve got a list of things to fix up,

Online

#72 2012-08-05 08:07:17

Pat64
Plugin Author
From: France
Registered: 2005-12-12
Posts: 1,018
Website

Re: Feedback to: Textpattern 4.5.0 Beta released

Hi all.

That’s off topic. Just for fun, here is a movie : playing with CSS transitions on the beautiful Remora theme.

http://www.screencast.com/t/ja1xdUZE2hWv

Last edited by Pat64 (2012-08-05 08:27:16)


Patrick.
Txp Tricks & Tips by french users : http://txp-fr.net | G+
Alison: a CSS Grid tool for all browsers

Offline

#73 2012-08-05 12:18:50

kevinpotts
Member
From: Kansas City
Registered: 2004-12-07
Posts: 364
Website

Re: Feedback to: Textpattern 4.5.0 Beta released

One very strange thing I am noticing is significant lag in articles updating using hak_tinymce.

If I make a change to a static file on the server (CSS), or to a form or page, I can see changes immediately. If I edit an article, changes take 10 minutes or more to actually go through. This delay is caused by hak_tinymce; if I disable the plugin, changes are instant.

Am I doing something wrong, or is this a plugin issue?

(I’ll log in a note in that plugin’s respective thread as well.)

UPDATE: Actually, it’s not a time issue, but that I have to click “Save” twice for changes to register.

Last edited by kevinpotts (2012-08-05 12:27:59)

Offline

#74 2012-08-05 13:59:10

kevinpotts
Member
From: Kansas City
Registered: 2004-12-07
Posts: 364
Website

Re: Feedback to: Textpattern 4.5.0 Beta released

Another interesting related to the Ajaxness of the Article screen … a checkbox option created with glz_custom_fields produces an error “Sorry the form could not be submitted. Please try again later.”

Offline

#75 2012-08-05 16:20:22

wet
Developer
From: Lenzing, Austria
Registered: 2005-06-06
Posts: 3,108
Website

Re: Feedback to: Textpattern 4.5.0 Beta released

kevinpotts wrote:

Am I doing something wrong, or is this a plugin issue?

A plugin issue. We expect a few inevitable incompatibilities with plugins for the write tab due to the new plugin types and AJAX adaptations.

Offline

#76 2012-08-06 07:00:03

phiw13
Plugin Author
From: Japan
Registered: 2004-02-27
Posts: 608
Website

Re: Feedback to: Textpattern 4.5.0 Beta released

Minor nitpick: in the set up process, last step, the final button looks slightly odd: screenshot

(height: 3em is the reason. fwiw)

Offline

#77 2012-08-07 03:16:47

gomedia
Plugin Author
Registered: 2008-06-01
Posts: 907
Website

Re: Feedback to: Textpattern 4.5.0 Beta released

I think I’ve found some issues with the Write tab & article posted/expires timestamps.

1) If you try to create a new article with Expires timestamp filled in, the article is saved with a blank Expires timestamp.

2) If you edit an article which already has Expires set & attempt to set it before Posted, a green “Article posted” message is displayed & the Expires timestamp is ignored. Shouldn’t there be a warning?

3) If you edit an article which already has Expires set & attempt to set the Posted timestamp to be after Expires, a green “Article posted” message is displayed & the Posted timestamp is saved. The database now has an article saved with Posted > Expires timestamps. Shouldn’t it be an error?

Using r4046.

Last edited by gomedia (2012-08-07 06:08:44)

Offline

#78 2012-08-07 17:20:28

maniqui
Moderator
From: Buenos Aires, Argentina
Registered: 2004-10-10
Posts: 2,989
Website

Re: Feedback to: Textpattern 4.5.0 Beta released

Tinkering (just a little) with TXP 4.5 Beta, on a multi-site config alla maniqui-style (will post about this later… will I?).
Installation process went pretty smooth.

So far, everything seems to be working fine. Great, beautiful work Thank you, Textpattern devs!


La música ideas portará y siempre continuará

TXP Builders – finely-crafted code, design and txp

Offline

#79 2012-08-08 02:17:41

gomedia
Plugin Author
Registered: 2008-06-01
Posts: 907
Website

Re: Feedback to: Textpattern 4.5.0 Beta released

Here’s a strange one. I have a TXP 4.5 (r4046 install), with no timezone set in Admin Prefs.

If I create an article, the Posted timestamp is 23 hours behind my local server.

From Diags:

Server TZ: Australia/Melbourne
Server local time: 2012-08-08 12:10:24
DST enabled?: 0
Automatically adjust DST setting?: 0
Time zone:  (-46800)

Is this expected behaviour? If, so why a 23 hour difference? As you can see I’m in a GMT+10 timezone. And I’m not sure what the -46800 is telling me (GMT-13?).

I normally set an explicit timezone as a matter of course, but I thought I’d better mention this scenario.

Offline

#80 2012-08-08 09:41:05

Destry
Moderator
From: Strasbourg, France
Registered: 2004-08-04
Posts: 2,365
Website

Re: Feedback to: Textpattern 4.5.0 Beta released

Since realizing there is no annoying jump-to-the-top-of-editor problem after saving in Write panel anymore — THANK YOU — can we get this added to all of the panel editors too, to be consistent. Styles especially could really use it.

I know, I know, all the hipsters want to use external editors and files on the server, etc, but, like I was saying before, the default context of this product is out-of-box, and that’s how people will first be using the tool to get familiar with it. Thus that’s where you should be first looking at making improvements.

Note I’m not railing devs here, just making it clear before someone jumps in with the expected “I don’t use the Style editor anyway…” blah, blah, blah. Well, if nobody uses the style editor, then why is it even in the system? Because people do use the style editor. It makes it easy in many cases, certainly at first. And it could be easier to use still. :)

/* Mom signing off */

Offline

Board footer

Powered by FluxBB