Textpattern Forum

You are not logged in. Register | Login | Help

#31 2010-11-05 12:47:58

maniar
Member
From: Hamilton, Ontario
Registered: 2010-01-04
Posts: 66
Website

Re: glg_subscribe_comments : subscribe to article's comments

Hi Grégocentrique: I was requested by one of my readers to have a comment subscribe by e-mail.

Everything works well except for the un-subscribe link in the e-mail. It goes to a 404 page ! Here is a sample unsubscription link (don’t worry it’s my own)

http://maniaravings.com/2010/11/04/dona-nobis-pacem-2010&glg_unsubscribe=bWluZXIucmF2aW5nc0BnbWFpbC5jb20%3D#glg_message

Hope you had a nice vacation !


اردو میں بھی دستیاب Textpattern آپ کے لیے اب

Offline

#32 2010-11-05 13:08:49

maniar
Member
From: Hamilton, Ontario
Registered: 2010-01-04
Posts: 66
Website

Re: glg_subscribe_comments : subscribe to article's comments

I am also getting the following error sometimes when moderating comments. It was addressd in the plugin page as well but I wonder if it is a safe solution.

Strict Standards: getdate() [function.getdate]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /public_html/textpattern/lib/txplib_misc.php on line 1262

Strict Standards: getdate() [function.getdate]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /public_html/textpattern/lib/txplib_misc.php on line 1262

Strict Standards: mktime() [function.mktime]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in/public_html/textpattern/lib/txplib_misc.php on line 1263

Strict Standards: mktime() [function.mktime]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /public_html/textpattern/lib/txplib_misc.php on line 1263

Strict Standards: timezone::is_dst() [timezone.is-dst]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /public_html/textpattern/lib/txplib_misc.php on line 1265

Strict Standards: Non-static method timezone::is_dst() should not be called statically in /home/maniar05/public_html/textpattern/lib/txplib_misc.php on line 1265

Strict Standards: strftime() [function.strftime]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /public_html/textpattern/lib/txplib_misc.php on line 1299

Strict Standards: strftime() [function.strftime]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /public_html/textpattern/lib/txplib_misc.php on line 1299

Strict Standards: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /public_html/textpattern/publish/comment.php on line 246

Strict Standards: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in /public_html/textpattern/publish/comment.php on line 246 @

Last edited by maniar (2010-11-05 13:10:07)


اردو میں بھی دستیاب Textpattern آپ کے لیے اب

Offline

#33 2010-11-20 00:10:54

Grégocentrique
Plugin Author
From: Rouen, France
Registered: 2009-12-19
Posts: 28
Website

Re: glg_subscribe_comments : subscribe to article's comments

scottcal wrote:

Been using glg_subscribe_comments and it has worked great in the past, but I recently upgraded to php 5 and I got some errors when approving the comments. The error:
Strict Standards: Non-static method timezone::is_dst() should not be called statically in /home/root/textpattern/lib/txplib_misc.php on line 1265
I fixed using the link below however the email no longer sends when someone comments on another person’s post that is subscribed. Anyone else had this issue?
Fix Thread

Hi Scottcal,

I finally took a look at your issue.

It seems to be a settings problem.

Could you turn off E_STRICT of error_reporting in php.ini?

If not, take a look at those pages to modify your txplib_misc.php : http://code.google.com/p/textpattern/issues/detail?id=48 and http://code.google.com/p/textpattern/source/detail?r=3284.

Tell me if you see a difference.

Last edited by Grégocentrique (2010-11-20 00:12:31)

Offline

#34 2010-11-20 00:20:11

Grégocentrique
Plugin Author
From: Rouen, France
Registered: 2009-12-19
Posts: 28
Website

Re: glg_subscribe_comments : subscribe to article's comments

maniar wrote:

I am also getting the following error sometimes when moderating comments. It was addressd in the plugin page as well but I wonder if it is a safe solution.

Hi Maniar,

Same problem than Scottcal, it seems to be a settings problem. Try to remove E_STRICT flag from error_reporting parameter.

maniar wrote:

Hope you had a nice vacation !

Thanks, that’s was very nice, but a lot of work was waiting me. ;)

I’m investigating your error 404 problem (I’ve just discovered your posts tonight).

Last edited by Grégocentrique (2010-11-20 00:24:41)

Offline

#35 2010-11-20 00:45:25

Grégocentrique
Plugin Author
From: Rouen, France
Registered: 2009-12-19
Posts: 28
Website

Re: glg_subscribe_comments : subscribe to article's comments

maniar wrote:

Hi Grégocentrique: I was requested by one of my readers to have a comment subscribe by e-mail.
Everything works well except for the un-subscribe link in the e-mail. It goes to a 404 page ! Here is a sample unsubscription link (don’t worry it’s my own)
http://maniaravings.com/2010/11/04/dona-nobis-pacem-2010&glg_unsubscribe=bWluZXIucmF2aW5nc0BnbWFpbC5jb20%3D#glg_message

Oh my god, what a creepy mistake. There is a “&” in place of a “?” in the URL.

You just found a bug, thank you.

To fix it, edit the plugin and change the line :

$sep = $prefs['url_mode'] == 1 ? '&' : '?';

to :

$sep = $prefs['permlink_mode'] === 'messy' ? '&' : '?';

I will include this fix in the next version of the plugin.

Offline

#36 2010-11-20 03:04:18

maniar
Member
From: Hamilton, Ontario
Registered: 2010-01-04
Posts: 66
Website

Re: glg_subscribe_comments : subscribe to article's comments

Oh ! I am very glad I could be of some help ! ({excitedly} This is my first ever successful bug report !)

Thank you !


اردو میں بھی دستیاب Textpattern آپ کے لیے اب

Offline

#37 2010-11-25 03:23:00

scottcal
Member
From: Encinitas, CA
Registered: 2010-09-04
Posts: 21
Website

Re: glg_subscribe_comments : subscribe to article's comments

Plan to take a look at things soon again and try your suggestions. I’ve been using the other plugin but I really like yours much better. Thanks for letting us know! :)

Offline

#38 2012-04-21 04:36:27

SuMu
Member
From: Germany - Wuppertal
Registered: 2008-03-06
Posts: 242
Website

Re: glg_subscribe_comments : subscribe to article's comments

Grégocentrique schrieb:

Double Opt in

It’s not implemented in glg_subscribe_comments, but it could be in the next version.
I add this feature on the todo-list.

HI,
Whats about this option? (Which version is this feature)


viele Grüße
SuMu

Psychomuell + blogZicke

Offline

#39 2012-06-06 06:02:07

Grégocentrique
Plugin Author
From: Rouen, France
Registered: 2009-12-19
Posts: 28
Website

Re: glg_subscribe_comments : subscribe to article's comments

Hi guys,

I’m sorry to reply so late.

Thanks for your interest in the plugin. I’m currently really busy and don’t have time to improve the plugins and work on the version 2. But the plugin is still on my todo list and I will work on it as soon as I get a little time.

Offline

#40 2012-07-15 12:52:59

quicknquiet
Member
From: Moscow
Registered: 2012-07-02
Posts: 11

Re: glg_subscribe_comments : subscribe to article's comments

I would be glad to help with Russian translation

Offline

Board footer

Powered by FluxBB