Textpattern Forum

You are not logged in. Register | Login | Help

#1 2011-01-03 20:42:15

lsnadon
New Member
From: Cheyenne WY
Registered: 2011-01-02
Posts: 6
Website

Visitor logs will only show 1st visitor (SOLVED)

Hello,

Since the last time I cleared my visitor logs, only the 1st visitor gets logged. I’ve checked this out by accessing my site from several locations to test it, always only the first hit gets logged and no other hits after that. If I delete that hit, then the very next hit gets logged, then it breaks again.

I am using smd_lately and it is currently active. Beyond that, I cannot figure out why nothing gets logged. My Apache logs do show visitors, just not Textpattern’s “Visitor Logs” (edit – smd_lately has been deactivated and delete/removed to eliminate that possibility).

Another edit – I have set logging to “all hits”, “referrer only” and “none” and back agin, hoping it would trigger something. Still happens – only 1st visitor gets logged.

Any ideas??

Thanks,

Les

p.s. – Yes, I also posted this message in “How do I….& Other Questions” but I think it might be more suited here. Correct me if I am wrong (or overly rude by cross-posting).

Last edited by lsnadon (2011-01-03 20:55:12)

Offline

#2 2011-01-03 20:59:22

lsnadon
New Member
From: Cheyenne WY
Registered: 2011-01-02
Posts: 6
Website

Re: Visitor logs will only show 1st visitor (SOLVED)

I turned on debugging and sure enough – there was the problem txp_log was not incrementing.

I moved my website from one server to another. Actually, I moved everything to a new server.

In the process of copying the MySql DB’s, every single one of them turned of “auto-increment”. Beats me why this happened. On all of my DB’s (which were broken), all I had to do was turn on “auto-increment”. I was not aware of the txp_log table inside of textpattern, therefore, I did not know to turn on “auto-increment”.

Problem solved….

Les

Offline

Board footer

Powered by FluxBB