Textpattern Forum

You are not logged in. Register | Login | Help

#1431 2009-10-19 15:49:05

Els
Admin
From: The Netherlands
Registered: 2004-06-06
Posts: 7,383
Website

Re: MLP - The Multi-Lingual Publishing Pack

Kemie, you can try to run the Cleanup wizard (don’t check the checkboxes under 3. and 4.), and then run the Setup wizard again. Probably MLP will create the missing ‘expires’ column in the per-language tables then. If it doesn’t, let me know.


<txp:Els /> ;)
Tag Reference | Unexpected behaviour? Check the tag trace | Still no clue? Check the names of your custom fields

Offline

#1432 2009-10-19 17:53:26

kemie
Plugin Author
From: mexico<-->sweden
Registered: 2004-05-20
Posts: 491
Website

Re: MLP - The Multi-Lingual Publishing Pack

Els,
that worked, thank you so much! :) :) :) :)


~~~~~~~~~~~~~| monolinea.com | pixilate.com | istockphoto.com/kemie |~~~~~~~~~~~~~

Offline

#1433 2009-10-21 16:26:11

MrLongbaugh
Member
From: Hamburg - Germany
Registered: 2004-10-11
Posts: 109

Re: MLP - The Multi-Lingual Publishing Pack

After upgrading to TXP 4.2.0 and l10n 0.9.13-gp I always get the error:

<txp:article allowoverride="1" form="Fotostrecke" limit="1" pgonly="0" searchall="0" searchsticky="0" status="5" /> ->  Textpattern Warning: Unknown column 'Expires' in 'field list'

Any idea how to solve that issue?

Offline

#1434 2009-10-21 16:31:02

Els
Admin
From: The Netherlands
Registered: 2004-06-06
Posts: 7,383
Website

Re: MLP - The Multi-Lingual Publishing Pack

You can try this.


<txp:Els /> ;)
Tag Reference | Unexpected behaviour? Check the tag trace | Still no clue? Check the names of your custom fields

Offline

#1435 2009-10-21 17:54:49

MrLongbaugh
Member
From: Hamburg - Germany
Registered: 2004-10-11
Posts: 109

Re: MLP - The Multi-Lingual Publishing Pack

thx Els. That fixed it.

Offline

#1436 2009-10-28 12:40:01

liniocht
Member
Registered: 2009-10-28
Posts: 45
Website

Re: MLP - The Multi-Lingual Publishing Pack

vandamar wrote:

I Els. I just have, on a third clean installation of TXP on a new database, with MLP 0.9.13 as the only plugin. Same problem persists; I am unable to edit section titles. :(
Anyone else having this exact problem?

Have exactly the same problem. TXP 4.2.0 with MLP 0.9.13 clean new installation with English and Russian languages. No other plugins. Section titles are not editable in Russian language.

Offline

#1437 2009-10-28 12:53:35

liniocht
Member
Registered: 2009-10-28
Posts: 45
Website

Re: MLP - The Multi-Lingual Publishing Pack

Here’s diagnostics:

Textpattern version: 4.2.0 (r3275)
Last Update: 2009-10-23 10:02:46/2009-08-28 19:31:19
Document root: /xxx-xxx
$path_to_site: /xxx-xxx
Textpattern path: /xxx-xxx/textpattern
Permanent link mode: section_id_title
Temporary directory path: /tmp
Site URL: xyz.com
PHP version: 5.2.0-8+etch15
GD Image Library: 2.0 or higher; supported formats: GIF, JPG, PNG.
Server TZ: System/Localtime
Server Local Time: 2009-10-28 15:50:40
DST enabled?: 0
Automatically adjust DST setting?: 0
Time Zone: (+14400)
MySQL: 5.0.32-Debian_7etch10-log
Locale: C
Server: Apache/1.3.34
Apache version: Apache/1.3.34
PHP Server API: apache
RFC 2616 headers:
Server OS: Linux 2.6.18
Active plugins: zem_contact_lang-mlp-4.0.3.6-ML, l10n-0.9.13-gp, gbp_admin_library-0.4.2
Admin-side theme: classic 4.2.0

Pre-flight check:
————————————
Some Textpattern files have been modified: /xxx-xxx/textpattern/lib/txplib_db.php
————————————

.htaccess file contents:
————————————
#DirectoryIndex index.php index.html

#Options +FollowSymLinks
#Options -Indexes

<IfModule mod_rewrite.c> RewriteEngine On #RewriteBase /relative/web/path/

RewriteCond %{REQUEST_FILENAME} -f [OR] RewriteCond %{REQUEST_FILENAME} -d RewriteRule ^(.+) – [PT,L]

RewriteCond %{REQUEST_URI} !=/favicon.ico RewriteRule ^(.*) index.php

RewriteCond %{HTTP:Authorization} !^$ RewriteRule .* – [E=REMOTE_USER:%{HTTP:Authorization}]
</IfModule>

#php_value register_globals 0

php_value upload_max_filesize 32M
php_value post_max_size 32M

————————————

Offline

#1438 2009-10-28 14:09:53

liniocht
Member
Registered: 2009-10-28
Posts: 45
Website

Re: MLP - The Multi-Lingual Publishing Pack

Some more info. As you see below categories created before installation of MLP have l10n_title_en_gb and 10n_title_ru_ru set to the same value – title field. But the sections created after MLP installation “Portfolio” and “Service” do not have l10n_title_en_gb and 10n_title_ru_ru at all!

mysql> select * from txp_section;
+-----------+---------+---------+------------+--------+--------------+------------+-----------+------------------+------------------+
| name      | page    | css     | is_default | in_rss | on_frontpage | searchable | title     | l10n_title_en_gb | l10n_title_ru_ru |
+-----------+---------+---------+------------+--------+--------------+------------+-----------+------------------+------------------+
| articles  | archive | default |          0 |      1 |            1 |          1 | Articles  | Articles         | Articles         |
| default   | default | default |          0 |      1 |            1 |          1 | default   | default          | default          |
| about     | default | default |          0 |      0 |            0 |          1 | About     | About            | About            |
| portfolio | default | default |          1 |      0 |            0 |          1 | Portfolio |                  |                  |
| service   | default | default |          0 |      1 |            1 |          1 | Service   |                  |                  |
+-----------+---------+---------+------------+--------+--------------+------------+-----------+------------------+------------------+

Offline

#1439 2009-10-28 17:23:22

Els
Admin
From: The Netherlands
Registered: 2004-06-06
Posts: 7,383
Website

Re: MLP - The Multi-Lingual Publishing Pack

liniocht wrote:

Some more info.

Thanks, I hope it tells Graeme something. I filed the issue, don’t know if it will help, because it still depends on how busy Graeme is.


<txp:Els /> ;)
Tag Reference | Unexpected behaviour? Check the tag trace | Still no clue? Check the names of your custom fields

Offline

#1440 2009-10-28 17:25:21

jpleboeuf
New Member
From: Prague, Czech Republic
Registered: 2009-10-08
Posts: 5
Website

Re: MLP - The Multi-Lingual Publishing Pack

A follow-up @ultramega & @graeme.

I have the same problem when using MLP on a website inside a subdirectory: random notices such as:

@Notice: Undefined index: l10n_request_uri in C:\XAMPP\xampp\htdocs\subdir\textpattern\lib\txplib_misc.php(594) : eval()'d code on line 431@

and no redirection happens.

With debugging enabled:

hu=http://localhost/subdir/ REQUEST = GET : string(1) "/"
array(5) { ["u0"]=> string(0) "" ["u1"]=> string(0) "" ["u2"]=> string(0) "" ["u3"]=> string(0) "" ["u4"]=> string(0) "" }

Checking browser accept-language headers.


L10N MLP: processing browser language header :string(35) "fr,fr-fr;q=0.8,en-us;q=0.5,en;q=0.3"
Deprecated: Function split() is deprecated in C:\XAMPP\xampp\htdocs\subdir\textpattern\lib\txplib_misc.php(594) : eval()'d code on line 238

Deprecated: Function split() is deprecated in C:\XAMPP\xampp\htdocs\subdir\textpattern\lib\txplib_misc.php(594) : eval()'d code on line 243
Setting language to fr-fr from browser headers


_l10n_set_browse_language( fr ) ... $site_langs=array(3) { [0]=> string(5) "fr-fr" [1]=> string(5) "cs-cz" [2]=> string(5) "en-gb" } , $tmp='fr-fr' ... in IF() ... $tmp [fr-fr] used to set $l10n_language to string(5) "fr-fr" returning TRUE

Input='fr', Site Language set to array(3) { ["short"]=> string(2) "fr" ["country"]=> string(2) "FR" ["long"]=> string(5) "fr-fr" } Returning bool(true)

New first path is:
Notice: Undefined index: l10n_request_uri in C:\XAMPP\xampp\htdocs\subdir\textpattern\lib\txplib_misc.php(594) : eval()'d code on line 431

My two cents: in the code, inside function _l10n_process_url(), one can read:

if( (@txpinterface==='public') && ('GET' === $req_method) && in_array( $request , $redirects ) )
		$redirect = true;

The problem seems that $redirect is never true if $request in not '' or '/', for example when inside a subdirectory.

Adding:

if ( $req === '/' ) { $redirect = true; };

after:

$subpath = preg_quote(preg_replace("/https?:\/\/.*(\/.*)/Ui","$1",hu),'/');
$req = preg_replace("/^$subpath/i",'/',$request);

seems to fix the problem:

hu=http://localhost/subdir/ REQUEST = GET : string(1) "/"
array(5) { ["u0"]=> string(0) "" ["u1"]=> string(0) "" ["u2"]=> string(0) "" ["u3"]=> string(0) "" ["u4"]=> string(0) "" }

Checking browser accept-language headers.


L10N MLP: processing browser language header :string(35) "fr,fr-fr;q=0.8,en-us;q=0.5,en;q=0.3"
Deprecated: Function split() is deprecated in C:\XAMPP\xampp\htdocs\subdir\textpattern\lib\txplib_misc.php(594) : eval()'d code on line 238

Deprecated: Function split() is deprecated in C:\XAMPP\xampp\htdocs\subdir\textpattern\lib\txplib_misc.php(594) : eval()'d code on line 243
Setting language to fr-fr from browser headers


L10N MLP: About to redirect to: http://localhost/subdir/fr/

That works only for the home page. Any other ideas?

(edited for better code display. -Els)

Last edited by Els (2012-02-20 13:41:36)

Offline

Board footer

Powered by FluxBB