Go to main content

Textpattern CMS support forum

You are not logged in. Register | Login | Help

#1 2013-11-30 12:42:48

Gallex
Member
Registered: 2006-10-08
Posts: 1,160

internal error "preg_replace(): the e / modifier is deprecated, use...

…preg_replace_callback instead”.
got this error during the installation of adi_notes-1.0 plugin.

txp: 4.5.5
PHP version: 5.5.2-pl0-gentoo

?

Last edited by Gallex (2013-12-01 08:43:17)

Offline

#2 2013-11-30 13:08:22

Gallex
Member
Registered: 2006-10-08
Posts: 1,160

Re: internal error "preg_replace(): the e / modifier is deprecated, use...

same with upm_image_popper… :(

Offline

#3 2013-11-30 14:04:04

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,225

Re: internal error "preg_replace(): the e / modifier is deprecated, use...

Re adi_notes: Are you using the most recent version? If so please post in its topic.


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#4 2013-12-01 13:17:35

uli
Moderator
From: Cologne
Registered: 2006-08-15
Posts: 4,225

Re: internal error "preg_replace(): the e / modifier is deprecated, use...

Gallex wrote:

PHP version: 5.5.2-pl0-gentoo

You added that today, did you?
As far as I remember PHP 5.5 support has only been added to the 4.6 dev version of TXP.

Edit: And I’m not getting errors on installation of upm_image_popper on a 4.5.4 TXP on PHP 5.4.

Last edited by uli (2013-12-01 13:19:32)


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#5 2013-12-02 11:24:13

Gocom
Plugin Author
From: Helsinki, Finland
Registered: 2006-07-14
Posts: 4,533
Website

Re: internal error "preg_replace(): the e / modifier is deprecated, use...

Textpattern 4.5.5 will work on PHP 5.5 just fine. But, you will get E_DEPRECATED notices, since it uses some deprecated features:

  • Textile v2.4.x: Textpattern 4.5.x uses the latest update in Textile 2.4 tree. 2.4 uses that deprecated regular expression modifier.
  • MySQL extension: Textpattern 4.5.x uses the legacy MySQL extension. This has been deprecated in PHP 5.5.

These are, for now, harmless and will go away if you turn your site to Live mode. In debugging and testing mode you will see these notices.

Last edited by Gocom (2013-12-02 11:26:41)

Offline

Board footer

Powered by FluxBB