Textpattern Forum

You are not logged in. Register | Login | Help

#61 2005-04-12 20:24:00

ruairi
Plugin Author
From: Madrid, Spain
Registered: 2005-04-05
Posts: 17
Website

Re: [archived] bsl_audioscrobbler

Another quick update. I’ve incorporated the fix described above. And bsl_audioscrobbler has a new attribute: preventcaching, which adds a parameter to the request to the audioscrobbler server to prevent caching of the response. I have a feeling that preventcaching should be used with restraint (ie only when your audioscrobbler feed doesn’t update, which is what was happening on my home connection).

bsl_audioscrobbler-0.8.1

Offline

#62 2005-05-11 19:42:37

The Safety Inspector
Member
From: London, UK
Registered: 2004-06-22
Posts: 32
Website

Re: [archived] bsl_audioscrobbler

Everytime I try to use any version of this plugin I get the following:

Fatal error: Call to undefined function: curl_init() in /home/hearth/public_html/textpattern/publish.php(767) : eval()’d code on line 374

I am using RC1.

No cache, just trying to start out with a really basic working installation.

Any ideas? Thanks.

Offline

#63 2005-05-12 10:56:25

ruairi
Plugin Author
From: Madrid, Spain
Registered: 2005-04-05
Posts: 17
Website

Re: [archived] bsl_audioscrobbler

Hi,

I had the same problem on a windows box. I hadn’t activated the CURL extension. Open your php.ini file and change the following line:

;extension=php_curl.dll

to

extension=php_curl.dll

restart Apache and your problem should be fixed.

Offline

#64 2005-05-15 07:13:51

lex
Member
From: Baltimore
Registered: 2004-04-23
Posts: 12

Re: [archived] bsl_audioscrobbler

All mine ever says is “not listening to music” :(


With an Apple, everything is either easy or impossible. – Unknown

Offline

#65 2005-06-22 19:17:50

paularms
Member
From: University of Minnesota
Registered: 2004-10-21
Posts: 155
Website

Re: [archived] bsl_audioscrobbler

Mine does not return authors using <code><txp:author /></code> as described in the documentation

Offline

#66 2005-06-25 17:08:44

paularms
Member
From: University of Minnesota
Registered: 2004-10-21
Posts: 155
Website

Re: [archived] bsl_audioscrobbler

Eh… forget that last post…

I have a feature request for this…
Instead of returning the notlisteningmessage, I wish there was a “not listening image” or were able to output a different form if there was no music playing.

Offline

#67 2005-06-29 21:04:52

RSL
Member
From: Decatur, GA
Registered: 2005-06-14
Posts: 15
Website

Re: [archived] bsl_audioscrobbler

Okay, I’ve searched everywhere for the reason why paularms retracted his post about the authors tag not working. I can’t get it to work either. What did you do that made it work? I’ve tried changing the form to all kinds of types. It should be on article though, right?

Offline

#68 2005-06-29 22:02:58

paularms
Member
From: University of Minnesota
Registered: 2004-10-21
Posts: 155
Website

Re: [archived] bsl_audioscrobbler

Try this, see if it helps (change your username and cache options)

Here is the call from the page template:
<code><txp:rmc_audioscrobbler username=“USERNAME” cachepath=“as_cache” cacheage=“1” limit=“10” form=“audio_center” notlisteningmessage=“Either Audioscrobbler is sucking or I’m not listening to music right now.” notworkingmessage=“Audioscrobbler is sucking at the moment. Please refresh the page.” /></code>

This is my form (type = misc)
<code><li><txp:as_link><txp:author /> – <txp:title /></txp:as_link></li></code>

Last edited by paularms (2005-06-29 22:03:52)

Offline

#69 2005-06-30 16:32:24

RSL
Member
From: Decatur, GA
Registered: 2005-06-14
Posts: 15
Website

Re: [archived] bsl_audioscrobbler

Still nothing. Are you using the other audioscrobbler plugin?

Offline

#70 2005-07-03 01:13:24

ruairi
Plugin Author
From: Madrid, Spain
Registered: 2005-04-05
Posts: 17
Website

Re: [archived] bsl_audioscrobbler

RSL: paularms is using my other audioscrobbler plugin. I’ve just noticed a bug in the documentation, where is says that txp:link should be used you should use txp:permlink instead. My bad, sorry. Try using this:

In your page template:

<ul>
<txp:bsl_audioscrobbler username="USERNAME" form="audioscrobbler" cachepath="./as_cache" />
</ul>

And your audioscrobbler form:

<li><txp:permlink><txp:title /> by <txp:author /></txp:permlink></li>

Paul: your wish is my command :p I’ve updated both audioscrobbler plugins, they now both support the attributes notlisteningform and notworkingform. You can get them from my website

Last edited by ruairi (2005-07-03 01:15:38)

Offline

Board footer

Powered by FluxBB