Textpattern Forum

You are not logged in. Register | Login | Help

#1 2012-01-22 11:15:56

dandul
Member
From: Brisbane, Australia
Registered: 2010-01-31
Posts: 33

Can't edit pages

Apologies if this has been answered somewhere else.

A site has recently stopped saving edits on pages. I can open the pages, change things but when I click save I get “404 Not Found – The requested resource was not found.”

I tried closing all the plug-ins, I’ve upgraded to 4.4.1. Still couldn’t save any changes.

For instance I can go to "http://www.shikota.net.au/textpattern/index.php?event=article&step=edit&ID=44" and edit it in the browser but I can’t save any changes, just get a 404 error. The one page I can edit is the front page "http://www.shikota.net.au".

I’m wondering if it’s a htaccess thing? The htaccess file is straight out of txp 4.14

#DirectoryIndex index.php index.html

#Options +FollowSymLinks
#Options -Indexes
#ErrorDocument 403 default

<IfModule mod_rewrite.c>
	RewriteEngine On
	#RewriteBase /relative/web/path/

	RewriteCond %{REQUEST_FILENAME} -f [OR]
	RewriteCond %{REQUEST_FILENAME} -d
	RewriteRule ^(.+) - [PT,L]

	RewriteCond %{REQUEST_URI} !=/favicon.ico
	RewriteRule ^(.*) index.php

	RewriteCond %{HTTP:Authorization}  !^$
	RewriteRule .* - [E=REMOTE_USER:%{HTTP:Authorization}]
</IfModule>

#php_value register_globals 0

If anyone has any ideas I’d be very grateful.


Stop wishing things were different to the way they are. Accept it, deal with it, move on.

Offline

#2 2012-01-22 12:41:56

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 4,928
Website

Re: Can't edit pages

Although the chances are that it might indeed be a problem to be solved with the htaccess file, did you check that there are not any problems with your database?


Yiannis
——————————
neme.org | neme-imca.org | hblack.net | LABS

Offline

#3 2012-01-22 13:57:52

Dragondz
Moderator
From: Algérie
Registered: 2005-06-12
Posts: 1,134
Website

Re: Can't edit pages

Humm

I not remeber exactly but i think i have red something similar and someone (i guess ruud) had said it s about the option “send header modification” in textpattern!! but i am not sure if it s that or another problem but that s easy to try!

Offline

#4 2012-01-22 15:07:36

wet
Developer
From: Lenzing, Austria
Registered: 2005-06-06
Posts: 3,097
Website

Re: Can't edit pages

This might be a side effect of a security measure (mod_security) your host has set up.

Try to add these lines to your .htaccess:

<IfModule mod_security.c>
SecFilterScanPOST Off
</IfModule>

Offline

#5 2012-01-23 08:48:51

dandul
Member
From: Brisbane, Australia
Registered: 2010-01-31
Posts: 33

Re: Can't edit pages

wet, added those lines to htaccess; didn’t fix it.

Dragondz, turned Send “Last-Modified” header? to “no”; didn’t fix it.

colak, I’m not sure how i’d check the integrity of the database. Can you point me to a how-to article? Is there a plug-in that can check. Apart from this (fairly major!) screw up it seems to be OK otherwise.

Thanks everyone.


Stop wishing things were different to the way they are. Accept it, deal with it, move on.

Offline

#6 2012-01-23 10:15:52

Dragondz
Moderator
From: Algérie
Registered: 2005-06-12
Posts: 1,134
Website

Re: Can't edit pages

Hi dnadul

For checking db you can use phpMyAdmin (your host must provide you that in hosting panel)

Offline

#7 2012-01-23 11:16:41

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 4,928
Website

Re: Can't edit pages

Also if your db is ok and the problem persists try to see what happens if you add these two lines at the top of your htaccess file

SecFilterEngine Off
SecFilterScanPOST Off

Yiannis
——————————
neme.org | neme-imca.org | hblack.net | LABS

Offline

#8 2012-01-23 11:24:09

dandul
Member
From: Brisbane, Australia
Registered: 2010-01-31
Posts: 33

Re: Can't edit pages

Yeah, did a check with MyPHPAdmin, all seems fine.

I think that because one page (the front page) is editable then it’s not a db issue.

Like I said, htaccess seems the logical place to look because it seems to be an access to the website issue. Sorry, it’s been a long day and I’m not being very clear.

Will keep trying, thanks for your help.


Stop wishing things were different to the way they are. Accept it, deal with it, move on.

Offline

#9 2012-01-23 11:27:43

dandul
Member
From: Brisbane, Australia
Registered: 2010-01-31
Posts: 33

Re: Can't edit pages

Thanks Colak, tried the two lines – got “500 internal server error”.

I appreciate the effort my friend.


Stop wishing things were different to the way they are. Accept it, deal with it, move on.

Offline

#10 2012-01-23 11:50:14

colak
Admin
From: Cyprus
Registered: 2004-11-20
Posts: 4,928
Website

Re: Can't edit pages

Try one line at a time. Sometimes just the first line solves the problem


Yiannis
——————————
neme.org | neme-imca.org | hblack.net | LABS

Offline

Board footer

Powered by FluxBB