Textpattern Forum

You are not logged in. Register | Login | Help

#1 2012-06-30 18:22:04

douglgm
Member
From: Bristol
Registered: 2006-08-23
Posts: 172
Website

[solved] Syndicate article excerpt only? admin setting ignored?

Bit of a strange one. I’ve got a site where regardless of the Syndicate article excerpt only? The site is using the excerpt if one exists in the RSS feed. Anyone else experienced this?

Offline

#2 2013-07-01 11:43:28

squirrellypoo
Member
Registered: 2006-06-20
Posts: 5

Re: [solved] Syndicate article excerpt only? admin setting ignored?

Did you ever get to the bottom of this one?

I’m experiencing the same issue – my site has always used full articles in my feeds, but after upgrading to the latest version of Textpattern (4.5.4), my admin setting is being ignored, and my feeds are only displaying the excerpts, which is driving me crazy.

Edit: to add more information, I’m looking at the code of the feed itself (through a feed validator), and it looks like in <description> it’s only the excerpt that’s being included, but then if I scroll further down, inside <content:encoded> for the same article, the full article is included. This seems really strange to me that’s it’s so inconsistent – how can I ensure that the full article is included in both <description> and <content:encoded> so that everyone sees the full article?

Can anyone help? Is there anywhere for me to manually edit the Feeds and override the admin setting? thanks.

Last edited by squirrellypoo (2013-07-01 11:55:54)

Offline

#3 2013-07-01 12:49:50

etc
Plugin Author
Registered: 2010-11-11
Posts: 1,062
Website

Re: [solved] Syndicate article excerpt only? admin setting ignored?

This tip?

Offline

#4 2013-07-01 13:28:14

squirrellypoo
Member
Registered: 2006-06-20
Posts: 5

Re: [solved] Syndicate article excerpt only? admin setting ignored?

etc wrote:

This tip?

Thanks, but that’s not really going to work, since it looks like it’d involve a) adding a new catchall tag for all articles going forward (messy, since I already use tags and display them everywhere), and b) forcing everyone to switch to the new RSS feed URL (a no-go since I’ve already gathered thousands of subscribers over the past 7 years).

Offline

#5 2013-07-01 13:37:48

etc
Plugin Author
Registered: 2010-11-11
Posts: 1,062
Website

Re: [solved] Syndicate article excerpt only? admin setting ignored?

squirrellypoo wrote:

a) adding a new catchall tag for all articles going forward (messy, since I already use tags and display them everywhere),

I’m a bit lost here, sorry.

b) forcing everyone to switch to the new RSS feed URL (a no-go since I’ve already gathered thousands of subscribers over the past 7 years).

Couldn’t you just redirect them?

Offline

#6 2013-07-01 13:47:28

squirrellypoo
Member
Registered: 2006-06-20
Posts: 5

Re: [solved] Syndicate article excerpt only? admin setting ignored?

etc wrote:

I’m a bit lost here, sorry.

The tip you posted adds a feed for each tag. I currently have something like 50 tags. In order to replicate a feed which covers everything I post, I’d have to create a new catchall tag, like “everything” then tag every single article with “everything” going forward in order to ensure it shows up in the “everything tag feed. But I display my tags everywhere on the site, so very shortly “everything” would be the most prominent tag in the cloud, and “everything” would appear at the bottom of every post, next to the tags which are actually relevant to the article content.

Couldn’t you just redirect them?

Yes, because users always do exactly what you tell them. Even if I’d remove mydomain.com/rss/ somehow and tell everyone to switch to the “everything” tag feed, only a small percentage would actually do so. I might as well just stop posting for the kill in readership this would accomplish. Changing the feed URL from one thing to another in each and every person’s feed reader of choice is something they’d have to do manually.

I really do thank you for at least replying and trying to help, I honestly do (I didn’t think anyone would even reply, seeing as how the first poster got zero replies after how many years), but the tag feed is a really clunky, backwards solution to the problem.

Offline

#7 2013-07-01 13:57:36

etc
Plugin Author
Registered: 2010-11-11
Posts: 1,062
Website

Re: [solved] Syndicate article excerpt only? admin setting ignored?

squirrellypoo wrote:

The tip you posted adds a feed for each tag.

Ah, ok, sorry. But you can certainly adapt it to your case, that’s only an example how to create a custom rss feed.

Couldn’t you just redirect them?

Yes, because users always do exactly what you tell them. Even if I’d remove mydomain.com/rss/ somehow and tell everyone to switch to the “everything” tag feed, only a small percentage would actually do so.

I mean automatic redirection with some .htaccess rule here, so mydomain.com/rss/ would actually point to mydomain.com/?rah_external_output=rss. The users don’t have to change anything (in theory).

Offline

#8 2013-07-01 19:36:59

Gocom
Developer
Registered: 2006-07-14
Posts: 4,403
Website

Re: [solved] Syndicate article excerpt only? admin setting ignored?

squirrellypoo wrote:

Did you ever get to the bottom of this one?

I believe, no; This topic sounds like slight confusion about what the preference really does.

There isn’t an option to disable excepts in feeds. Toggling the Syndicate article excerpt only?, doesn’t disable excepts, but can only disable the (additional) content field included in your feeds.

I’m experiencing the same issue – my site has always used full articles in my feeds, but after upgrading to the latest version of Textpattern (4.5.4), my admin setting is being ignored, and my feeds are only displaying the excerpts, which is driving me crazy.

Unfortunately the feeds between 4.5.4 and 4.4.1 are, well, identical. The setting mentioned, when toggled to Yes, makes so that the body is used as the description when the except isn’t set, and removes the additional body content (that content field). Feeds will always use excepts as the description if it’s available, regardless the setting.

If the option is set to No, the excerpt is used as the description and the body content as the content. Missing fields are omitted as needed.

how can I ensure that the full article is included in both <description> and <content:encoded> so that everyone sees the full article?

Unfortunately there isn’t an built in option for that. That there is the intended behavior. Been like that from the get-go.


Rah-plugins | What? I’m a little confused… again :-) <txp:is_god />

Offline

Board footer

Powered by FluxBB