Textpattern Forum

You are not logged in. Register | Login | Help

#1181 2012-06-15 09:56:33

RedFox
Member
From: Netherlands
Registered: 2005-03-25
Posts: 522
Website

Re: zem_contact_reborn 4.0.3.20

@txpdevcoder: Thanks.

The code that works almost perfect: <txp:zem_contact_select label="Aktiviteit" list="<txp:article_custom wraptag="" break="," category="formulier" limit="20" ><txp:title /></txp:article_custom>" break="<em>*</em></li><li>" />

But now there are UTF characters in the titles. See the form … how do I solve this?

Offline

#1182 2012-06-15 10:03:22

txpdevcoder
Member
Registered: 2012-06-07
Posts: 58

Re: zem_contact_reborn 4.0.3.20

I think its becase you have but the comma into the break tag, and TXP is converting it to html. You need to escape the caracter i think, or dont put it in the break. i put mine after the title tag, and left the break empty, did this not work?

Last edited by txpdevcoder (2012-06-15 10:07:27)

Offline

#1183 2012-06-15 13:10:45

RedFox
Member
From: Netherlands
Registered: 2005-03-25
Posts: 522
Website

Re: zem_contact_reborn 4.0.3.20

No, it didn’t work … :(

The question is now how to escape the HTML … !?

Offline

#1184 2012-06-15 13:14:12

txpdevcoder
Member
Registered: 2012-06-07
Posts: 58

Re: zem_contact_reborn 4.0.3.20

usually it is a back slash, but maybe not for textpattern…. try:

<txp:zem_contact_select label=“Aktiviteit” list=”<txp:article_custom wraptag=”“ break=”\,” category=“formulier” limit=“20” ><txp:title /></txp:article_custom>” break=”<em>*</em></li><li>” />

Offline

#1185 2012-06-15 13:20:34

uli
Moderator
From: Cologne/Köln
Registered: 2006-08-15
Posts: 3,046

Re: zem_contact_reborn 4.0.3.20

Try <txp:title no_widow="0" />


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#1186 2012-06-15 13:29:27

RedFox
Member
From: Netherlands
Registered: 2005-03-25
Posts: 522
Website

Re: zem_contact_reborn 4.0.3.20

It works! Thanks uli and txpdevcoder … :)

But what does no_widow="0" do? The docs say > ‘- allow the last word in the title to appear on its own line, i.e. the title content is rendered unchanged’ … magic I suppose!

Last edited by RedFox (2012-06-15 13:38:19)

Offline

#1187 2012-06-15 13:30:57

txpdevcoder
Member
Registered: 2012-06-07
Posts: 58

Re: zem_contact_reborn 4.0.3.20

no problem, did the escape work or <txp:title no_widow=“0” />?

Offline

#1188 2012-06-15 13:40:12

RedFox
Member
From: Netherlands
Registered: 2005-03-25
Posts: 522
Website

Re: zem_contact_reborn 4.0.3.20

@txpdevcoder: see my post before your latest …

Last edited by RedFox (2012-06-15 13:41:06)

Offline

#1189 2012-06-15 14:48:05

uli
Moderator
From: Cologne/Köln
Registered: 2006-08-15
Posts: 3,046

Re: zem_contact_reborn 4.0.3.20

RedFox wrote:

But what does no_widow="0" do? The docs say > ‘- allow the last word in the title to appear on its own line, i.e. the title content is rendered unchanged’ … magic I suppose!

The widow pref decides whether an & #160 ; (aka non-breaking space, which I saw in your select) is inserted between the last two words of an article title. The attribute in the title tag can overrule the pref setting.

Last edited by uli (2012-06-15 14:50:19)


In bad weather I never leave home without wet_plugout, smd_where_used and adi_form_links

Offline

#1190 2012-06-15 20:48:10

Els
Admin
From: The Netherlands
Registered: 2004-06-06
Posts: 7,383
Website

Re: zem_contact_reborn 4.0.3.20

RedFox wrote:

@Els: Mm … I can’t get a .htaccess file (with ‘SecFilterScanPOST Off’) into /textpattern … !? … what has to be the precise content of that file, Els?

Just that line, as far as I know. I don’t understand why you can’t get the file in /textpattern… Just create the file locally and FTP it?


<txp:Els /> ;)
Tag Reference | Unexpected behaviour? Check the tag trace | Still no clue? Check the names of your custom fields

Offline

Board footer

Powered by FluxBB