Textpattern Forum

You are not logged in. Register | Login | Help

#421 2007-11-12 05:43:51

net-carver
Admin
From: UK
Registered: 2006-03-08
Posts: 1,648

Re: MLP - The Multi-Lingual Publishing Pack

Re: Corrupt file downloads…

Can anyone confirm that removing the BOM from l10n_base.php fixed the ‘corrupt file download’ problems?

Edit Scratch that, it’s not the BOM, it seems to be a stray linefeed getting into the output buffer.

Edit2 File download bug seems to be fixed on my local installation.

Last edited by net-carver (2007-11-12 13:43:37)


Steve
Textile | My plugins on GitHub | @netcarver

Offline

#422 2007-11-12 07:57:13

jakob
Moderator
From: Germany
Registered: 2005-01-20
Posts: 1,912
Website

Re: MLP - The Multi-Lingual Publishing Pack

steve, nice to see you back!


TXP Builders – finely-crafted code, design and txp

Offline

#423 2007-11-12 12:28:43

net-carver
Admin
From: UK
Registered: 2006-03-08
Posts: 1,648

Re: MLP - The Multi-Lingual Publishing Pack

jakob

Thanks, nice to be posting to the forum again.

Can I ask what setups (OS+AMP versions) you are running currently and if you might be able to help out with some testing?


Steve
Textile | My plugins on GitHub | @netcarver

Offline

#424 2007-11-12 14:24:31

net-carver
Admin
From: UK
Registered: 2006-03-08
Posts: 1,648

Re: MLP - The Multi-Lingual Publishing Pack

All

Here is a (very) partial list of bugs/odities and their current status on my 4.05 installation:
Admin interface…

  1. Totally blank content > write tab. — Fixed, pending further testing.
  2. “Missing ID” warnings in the content > renditions tab. — Fixed, pending further testing.
  3. Language switcher drop-down only showing default language. — Fixed, pending further testing.
  4. Missing translation textareas for plugin strings and snippets. — Fixed, pending further testing.
  5. File uploads fail, jumps to content > write tab. — False report, working ok.
  6. Missing translation fields for section titles (thanks beztak). — Fixed, pending further testing.
  7. Translated image alt/captions dropped (thanks beztak). — Fixed, pending further testing.
  8. Translated category titles dropped (thanks jstubbs). — Fixed, pending further testing.
  9. Byte Order Mark in output (thanks Els/Ruud). — Fixed

Public interface…

  1. File downloads corrupted. — Fixed(?) code released for public testing.

Known limitations…

  1. Sub-directory installs not supported.
  2. Cannot sort using some localised fields.

Non-starters (not so much MLP problems, rather admin/user mis-configurations or expectations)

  1. Please output images (specifically) flags for languages. — If you really want to do this, Marios describes how to do so here.

Other items of note (that don’t manifest on my installation)…

Installation issues

  1. Installation blocks with error about missing MySQL privileges — Open, this will require some thinking + coding.
  2. Language table creation fails. — Open.

Anything major I’ve missed? If so, please post a very short description with a link back to the post in this thread that describes the issue in more detail. NB: Please don’t post about the fatal error on line 490 of l10n_admin.php, that one’s fixed locally already (it was causing the blank content > write tab.)

Thank you!

Last edited by net-carver (2007-11-13 17:23:34)


Steve
Textile | My plugins on GitHub | @netcarver

Offline

#425 2007-11-12 14:34:15

beztak
Member
From: Czech Republic
Registered: 2005-07-21
Posts: 184
Website

Re: MLP - The Multi-Lingual Publishing Pack

Missing translation inputs for section titles.

Offline

#426 2007-11-12 15:42:56

net-carver
Admin
From: UK
Registered: 2006-03-08
Posts: 1,648

Re: MLP - The Multi-Lingual Publishing Pack

beztak

thank you for the reply. All seems well with my updated local install.

Just to confirm, please can you let me know if you are expecting to see something like this…

However, I haven’t tried reproducing this on a fresh (un-patched) MLP installation yet.

Will keep you posted.


Steve
Textile | My plugins on GitHub | @netcarver

Offline

#427 2007-11-12 15:51:00

beztak
Member
From: Czech Republic
Registered: 2005-07-21
Posts: 184
Website

Re: MLP - The Multi-Lingual Publishing Pack

net-carver wrote:

Just to confirm, please can you let me know if you are expecting to see something like this…

That’s it ;)

Offline

#428 2007-11-12 15:54:50

beztak
Member
From: Czech Republic
Registered: 2005-07-21
Posts: 184
Website

Re: MLP - The Multi-Lingual Publishing Pack

Oh, that’s not all, I forgot about missing translation ALT and DESCRIPTION in image tab. When I upload image, there are only fields for default language. When I save it and again open than appear translation filed but when filled and saved translation disappear.

And maybe the same for file tab (not sure).

Last edited by beztak (2007-11-12 15:55:42)

Offline

#429 2007-11-12 15:55:10

zoltandragon
Member
Registered: 2007-04-30
Posts: 43

Re: MLP - The Multi-Lingual Publishing Pack

Steve – this is amazing! You’re solving all the problems in one single day?! Blessed be thy name!

Offline

#430 2007-11-12 16:17:38

net-carver
Admin
From: UK
Registered: 2006-03-08
Posts: 1,648

Re: MLP - The Multi-Lingual Publishing Pack

zoltandragon wrote:

Steve – this is amazing! You’re solving all the problems in one single day?!

It’s strange how some distance from your previous work can give some clarity.

However, please note, the changes I’m making to my local copy are, as yet, untested on other OS-webserver-PHP-MySQL combinations. What’s working on my box might break something else (particularly PHP 4 installs). These will need to be tested and I’m sure folks will help out with that :O)

Blessed be thy name!

Rubbish. I’m human.


Steve
Textile | My plugins on GitHub | @netcarver

Offline

Board footer

Powered by FluxBB